Thursday, December 8, 2011

TRANSPARENT BRIDGING IRB BRIDGING AND FALL BACK BRIDGING

Transparent Bridging

  • We may want to transport non routable protocols e.g netbios transparently from one end point to another
  • We may just want to have two segements appear to be directly connected over multiple physical routed segements.
  • Bridging and switching are very similar concepts switching being done in hardware while bridging being done in software in the first scenerio we will configure bridging acrosss cisco routers using cisco ios
Commands

bridge "no" protocol "protocol" - common ieee for stp or dcenet netbios so on

interface serial 0/0
bridge-group "no"




LAB

we will  join router r1 to r2 bridging through r5 and r4

R1(10.229.253.1)>>>sw1(vlan100)>>>r5(transbrid)>>>frame-relay>>>>r4(transbridge)>>>s2
(vlan 100)>>>>r2(10.229.253.2)
So r1 connects to switch 1 int fa0/1 which is in vlan 100 then switch1 fa0/5 connects
to r5 also in vlan 100 r5 (dlci 504) connects to r4 (dlci 405) over frame-relay r4
connects to sw2 int fa0/4 in vlan 100 s2 connects to r2 on fa0/2 in vlan 100
so r5 and r4 are transparent bridges r1 has ip of 10.229.253.1 and r2 has an ip of
10.229.253.2 at the end i should be able to ping both ways

I will just show the router configs the switches just have the ports in vlan 100
switchport access vlan 100
R1
----
r1#sh run int fa0/0
Building configuration...
Current configuration : 97 bytes
!
interface FastEthernet0/0
 ip address 10.229.253.1 255.255.255.0
 duplex auto
 speed auto
end
r1#

r5
----
bridge 1 protocol ieee
no ip routing

interface FastEthernet0/0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
end
r5#

r5#sh run int s0/0/0
Building configuration...
Current configuration : 144 bytes
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
 no ip route-cache
 frame-relay map bridge 504 broadcast
 bridge-group 1
end
r5#

r5#sh frame-relay map
Serial0/0/0 (up): bridge dlci 504(0x1F8,0x7C80), static,
              broadcast,
              CISCO, status defined, active
r5#


r5#sh bridge
Total of 300 station blocks, 296 free
Codes: P - permanent, S - self
Bridge Group 1:
    Address       Action   Interface       Age   RX count   TX count
001b.2bec.8386   forward   Serial0/0/0       0         42          0
001a.a264.df80   forward   Serial0/0/0       0          6          5
000d.2870.2040   forward   FastEthernet0/0   0          5          4
0011.bb89.6e07   forward   FastEthernet0/0   0         42          0
r5#

r4
------
bridge 1 protocol ieee
no ip routing
r4#sh run int serial 0/0/0
Building configuration...
Current configuration : 144 bytes
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
 no ip route-cache
 frame-relay map bridge 405 broadcast
 bridge-group 1
end
r4#

r4#sh run int f0/0
Building configuration...
Current configuration : 108 bytes
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
end

r4#sh frame-relay map
Serial0/0/0 (up): bridge dlci 405(0x195,0x6450), static,
              broadcast,
              CISCO, status defined, active
r4#
r2
---

r2#sh run int fa0/0
Building configuration...
Current configuration : 97 bytes
!
interface FastEthernet0/0
 ip address 10.229.253.2 255.255.255.0
 duplex auto
 speed auto
end

r2#ping 10.229.253.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.229.253.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/74/ ^x76 ms
r2#


IRB Integrate Routing & Bridging

  • IRB (integrated routing & bridging allows you to route & bridge same protocol stack in on single router) It also allows communication between the bridge and routing protocols
  • you use a bridge virtual interface (bvi) to connect bridge domain with routed comain it is a same principal of svi on multilayer switches

Commands

bridge irb
bridge "no" protocol ieee
bridge "no" route ip

interface bvi "no"
ip address "ip"


LAB
in this lab i basically connected switch 4 using a routed layer port on switch 4 with an ip
address 172.25.12.2 it connect to router 4 they will run a eigrp routing process
between them in the end i should from switch 4 able to reach r1 or r2 and vice versa
+ r1 and r2 should still have connectivity

r4
---
ip routing
bridge irb
bridge 1 protocol ieee
bridge 1 route ip

interface BVI1
 ip address 10.229.253.4 255.255.255.0   >>> has to be an address in the bridge      
                                       network
interface FastEthernet0/1
 ip address 172.25.12.1 255.255.255.0
 duplex auto
 speed auto
router eigrp 1
 network 10.229.254.0 0.0.0.255
 network 10.0.0.0
 network 172.25.0.0
 no auto-summary

on r2 i added a static route to 172.25.13.2

From R2 I can now ping
r2#ping 172.25.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.25.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r2#

From Sw4
switch4#ping 10.229.253.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.229.253.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
switch4#
From r2 i can still reach 10.229.253.1
 r2#ping 10.229.253.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.229.253.1, timeout is 2 seconds:
!!!!!
Success r

so basically the traffic is being bridged to 10.229.253.2 and routed to 172.25.12.2
so the bvi is combining the bridging and routing domian

FALL BACK BRIDGING

  • combination of routing & bridging at the same time for catalyst ios
  • the catalyst for the cisco switch 3560 supports routing for ipv4 & ipv6 all other protocols must be bridged e.g ipx netbios etc
  • the issue that fall back bridging address is in using route protocols such as ip we can cross vlan boundaries by using the routing between vlan interaaces using non routed protocl like ipx apple talk netbios and other legacy protocols we do not have this option fall back bridging is feature to allow this
Commands

bridge "no" protocol vlan-bridge

int s0/0
bridge-group 1

LAB

ok the scenerio is
r1 is connected to s1 via the switch 1 fa0/1 interface which is in vlan 10.SW1 is
configure with svi for vlan 10 10.0.0.1 255.255.255.0   
r5 is connected to s1 via the switch 1 interface fa0/5 which is vlan 20
S1 is configured with a svi for vlan 20 of 20.0.0.1 255.255.255.0
ipx will be configured on r1 and r5 both in ipx network a and they should be able to
ping

R1
---
r1#sh run | begin ipx
ipx routing 0001.0001.0001   - enable ipx routing

interface FastEthernet0/0
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
 ipx network A          - enable interface fa0/0 in ipx network a
end
r1#
r1#sh run | begin ip route
ip route 20.0.0.0 255.255.255.0 10.0.0.1   -add static route to the 20.0.0.0 network

s1
--
Ip routing
interface Vlan10
 ip address 10.0.0.1 255.255.255.0
 bridge-group 1
!
interface Vlan20
 ip address 20.0.0.1 255.255.255.0
 bridge-group 1                           - creating svi adding the bridge group

bridge 1 protocol vlan-bridge - enabling fall back bridging

r5
---

ipx routing 0001.0001.0001 - enabling ipx routing

ip route 10.0.0.0 255.255.255.0 20.0.0.1 - adding the route to the 10 network
r5#sh run int fa0/0
Building configuration...
Current configuration : 108 bytes
!
interface FastEthernet0/0
 ip address 20.0.0.2 255.255.255.0
 duplex auto
 speed auto
 ipx network A                       - adding an ip and ipx network to int fa0/0


so run sh ipx interface to get the ipx address of r5
r5#sh ipx interface
FastEthernet0/0 is up, line protocol is up
  IPX address is A.0013.19d6.f4d2, NOVELL-ETHER [up]
  Delay of this IPX network, in ticks is 1
  IPXWAN processing not enabled on this interface.
  IPX SAP update interval is 60 seconds
  IPX type 20 propagation packet forwarding is disabled
  Incoming access list is not set
  Outgoing access list is not set
  IPX helper access list is not set
  SAP GGS output filter list is not set
  SAP GNS processing enabled, delay 0 ms, output filter list is not set
  SAP Input filter list is not set
  SAP Output filter list is not set
  SAP Router filter list is not set
  Input filter list is not set
  Output filter list is not set
  Router filter list is not set
  Netbios Input host access list is not set
  Netbios Input bytes access list is not set
  Netbios Output host access list is not set
  Netbios Output bytes access list is not set
  Updates each 60 seconds aging multiples RIP: 3 SAP: 3
  SAP interpacket delay is 55 ms, maximum size is 480 bytes
  RIP interpacket delay is 55 ms, maximum size is 432 bytes
  RIP response delay is not set
  IPX accounting is disabled
  IPX fast switching is configured (enabled)
  RIP packets received 0, RIP packets sent 1, 0 Throttled
  RIP specific requests received 0, RIP specific replies sent 0
  RIP general requests received 0, 0 ignored, RIP general replies sent 0
  SAP packets received 0, SAP packets sent 1, 0 Throttled
  SAP GNS packets received 0, SAP GNS replies sent 0
  SAP GGS packets received 0, 0 ignored, SAP GGS replies sent 0
r5#


From R1 i am able to ping the address
r1#ping ipx A.0013.19d6.f4d2
Type escape sequence to abort.
Sending 5, 100-byte IPX Novell Echoes to A.0013.19d6.f4d2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r1#

this confirms the fall back bridging functioning as expected

2 comments:

  1. in IRB example..you cannot ping routed port of switch4 (172.25.12.2) from R2, because switch4 will sendback packet to the left side of network because it has in its routing table network 10.229.253.0 learned from R4. In other words..switch 4 doesnt know about 10.229.253.0 newtork on his right side (port on router 2) ?

    ReplyDelete
    Replies
    1. nevermin..it works..point is u need to have two links from switch4 to R4..one for bridging (link from first example) and new link for routed port

      Delete