Monday, December 26, 2011

EIGRP MISC

Ok we will now look at some miscellaneous EIGRP Features this will wrap up on eigrp.

next hop self
-------------
on updates say in nbma hub and spoke topology the spoke advertised to the hub we may
on the hub wish to specify our selves as the next hop when advertising down the route
to other spokes
this can be done with the
ip eigrp next-hop-self command at interface level

ip eigrp next-hop-self is default on the newer ios

maximum prefix
---------------
on a neighbor basis we can specify a limit on the number of prefix we will accept
from a neighbor if it goes over limit the adjacency will be torn down
router eigrp
neighbor ip address maximum-prefix " no"
Bandwidth Pacing
-----------------
This can be used in situation where several neighbor are connected to the same router
using a serial link over a single low speed frame relay network. By default eigrp limits that it can only use 50 percent of the bandwidth on the link. if it is very slow link we might starve eigrp with this so can change it
you put on an interface level
int fa0/0
ip bandwidth percent eigrp "as no" " percent"

EIGRP NEIGHBOR LOGGING
------------------------
We can log eigrp changes + warnings to the buffer
using the
router eigrp 1
eigrp log-neighbor-changes - will log changes in neighbor  state changes
router eigrp 1
eigrp log-neighbor-warnings - will log neighbor warning messages

these two logging are on by default
EIGRP MAX HOP COUNT
----------------------
EIGRP as distant vector protocol does have ahop and there is a hop maximum of 254
meaning the network should not be more than 254 hops end to end. The default is 100
hops you manual change to 254 hops or lower if you want
you can do this with the command
metric-maximum-hops "number" this is under the eigrp process
hops are not used for metric computation is eigrp 

LAB
-----
For the lab we will setup a frame relay partial mesh r1 will be the hub will connect
to both r4 and r5. R4 and R5 will have no direct connection

r4
---

r4(config)#int s0/0/0
r4(config-if)#encap frame-relay
r4(config-if)#no frame-relay  inverse
r4(config-if)#ip address 10.229.254.4 255.255.255.0
r4(config-if)#frame-relay  map ip 10.229.254.1 401 broadcast

r4(config)#int lo4
r4(config-if)#ip address 4.4.4.4 255.255.255.255
r4(config-if)#
r4(config)#router eigrp 1
r4(config-router)#no auto
r4(config-router)#network 10.229.254.0 0.0.0.255
r4(config-router)#network 4.4.4.4 0.0.0.0
r4(config-router)#

r1
---
interface Serial0/0
 ip address 10.229.254.1 255.255.255.0
 encapsulation frame-relay
 no ip split-horizon eigrp 1
 frame-relay map ip 10.229.254.4 104 broadcast
 frame-relay map ip 10.229.254.5 105 broadcast
 frame-relay lmi-type cisco

notice i do no ip split as it is a multipoint frame relay hub router
r1#sh run | begin router eigrp
router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 10.229.254.0 0.0.0.255
 no auto-summary
r5
---
r5(config)#int s0/0/0
r5(config-if)#encap frame
r5(config-if)#frame-relay map ip 10.229.254.1 501 broadcast
r5(config-if)#ip address 10.229.254.5 255.255.255.0
r5(config-if)#no frame-relay  inverse

r5(config)#router eigrp 1
r5(config-router)#network 5.5.5.5 0.0.0.0
r5(config-router)#network 10.229.254.0 0.0.0.255
r5(config-router)#
r5(config-router)#no auto

ok so it is all setup
ok to show the ip next hop behaviour on the newer ios like the one i am currently
using on the interface the default behaviour is ip next-hop-self eigrp 1 we will
change this to no ip next-hop-self eigrp 1 on r1 s0/0/0 int

r1
---
r1(config)#int s0/0
r1(config-if)#no ip next-hop-self eigrp 1
r1(config-if)#

r5
---

r5#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
  Known via "eigrp 1", distance 90, metric 129152000, type internal
  Redistributing via eigrp 1
  Last update from 10.229.254.4 on Serial0/0/0, 00:01:02 ago
  Routing Descriptor Blocks:
  * 10.229.254.4, from 10.229.254.1, 00:01:02 ago, via Serial0/0/0
      Route metric is 129152000, traffic share count is 1
      Total delay is 45000 microseconds, minimum bandwidth is 20 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2
r5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
   
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/129152000] via 10.229.254.4, 00:01:23, Serial0/0/0
if you notice the 4.4.4.4 is using 10.229.254.4 as a next hop

we have no direct connection to 10.229.254.4

r5#
r5#sh frame-relay map
Serial0/0/0 (up): ip 10.229.254.1 dlci 501(0x1F5,0x7C50), static,
              broadcast,
              CISCO, status defined, active
r5#

r5#ping 4.4.4.4 source 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 5.5.5.5
.....
Success rate is 0 percent (0/5)
r5#

ok now on r1 we will change the behaviour back to ip next-hop-self eigrp 1 on r1 s0/0

r1
--

r1(config)#int s0/0
r1(config-if)#ip next-hop-self eigrp 1
r1(config-if)#

r5
--
r5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/2297856] via 10.229.254.1, 00:01:16, Serial0/0/0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/129152000] via 10.229.254.1, 00:01:14, Serial0/0/0
r5#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
  Known via "eigrp 1", distance 90, metric 129152000, type internal
  Redistributing via eigrp 1
  Last update from 10.229.254.1 on Serial0/0/0, 00:01:55 ago
  Routing Descriptor Blocks:
  * 10.229.254.1, from 10.229.254.1, 00:01:55 ago, via Serial0/0/0
      Route metric is 129152000, traffic share count is 1
      Total delay is 45000 microseconds, minimum bandwidth is 20 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

the 4.4.4.4 next hop is not 10.229.254.1 r1 which is directly connected
r5#ping 10.229.254.1 source 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.229.254.1, timeout is 2 seconds:
Packet sent with a source address of 5.5.5.5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/65/68 ms
r5#

i can now ping successifully

No comments:

Post a Comment