Wednesday, December 21, 2011

EIGRP SCALABILITY

The next thing i looked at today was eigrp scalability
EIGRP can achieve sub-second reconvergence after a link failure with the use of
feasible succesor. ROutes that passed feasible condition and confirmed for certain to
be loop free.
If there is no feasible successor and the router stops recieving updates for the
route. The router will generate a query message and send it to all neighbors
requesting an alternate path. If the neighbors also have not recieved updates they
will query there neighbors this query process filters through the eigrp enviorment.
This is one of the slow down points in the eigrp protocol. We need to wait for all
routers to reply before we take the current route out of the topology table and
recalculate. In large eigrp domains what can happen is that not all routers reply
before the query timer expires. The routes goes into what is known is stuck in
active. When the timer expires query is not recieved from a neighbor the neighbor
relationship will be reset and routes relearnt the problem for 1 network going down
you could potential disrupt all networks.
This is why it is very important to design eigrp with feasible succesor in mind.
There is ways to bound the query domain You can do in either of 2 ways or both
1) Using Summary routes
2) Using Stub

EIGRP SUMMARIZATION
-----------------------
for eigrp summarys
on the interface
ip summary-address eigrp 'as' [network] [mask] [ad]
  - eigrp is not like rip it will support any bit boundary so you are not limited for
summarisinng in the bit     boundary
  - It automatically supresses the specfic subnets when the summary route is
advertised
  - We can allow specfic subnets to be allowed using the leak map command
  - admin distance defaults to 5 can be edited if required
  - it auto generates a discard route pointing at null 0 for the summary address
Another way we can boundary the query domain is through the use of stub networks
When a router does not have any downstream networks or it is not transitted by other
switches we can define this areas as stub to prevent querys been sent down in this
situation there is no point in querying a switch if it has no downstream paths.
You configure a stub by using the
router eigrp 1
eigrp stub ' arguments' the default arguments are connected and summary this means it
will advertised connected and summary routes only.
A router will inform it neighbor of it stub status during the neighbor adjacency
forming
If at a later you joined another neighbor to the stub switch/router. The stub
switch/router will not advertise the networks up to the non stub switch/router so you
could lose reachability for the router just joined
There is ways to use a leak map to leak in these networks

LAB
----
I will do a few lab scenerios on this
1)LAB will r4 is generating loopback advertisments to sw2 sw2 has a connection to sw3
and sw4
When a loopback goes down sw2 will query sw3 and sw4. We know this is a waste so we
look at a solution using summarization to stop this.
2)We will show an issue with null 0 and how to resolves Sw1 is advertising routes via
eigrp to switch 2  we will summarise to routes to switch r5  sw4 is advertising a
default route to sw2 
3) SHow an example of leaking map leaking in specfic subnet to make it appear more
desirable to go that path
   sw2 is leaking a specfic subent to sw4 over sw3
4) Set r4 as a stub and watch eigrp query proces by bringing down networks also do stub leaking


LAB1
----
ok so i have configured all the switches in the eigrp 1 routing domain




ok i have created 3 loopbacks on r4
Loopback0                  10.10.0.1       YES manual up                    up 
Loopback1                  10.10.1.1       YES manual up                    up 
Loopback2                  10.10.2.1       YES manual up                    up 

i done the dollowing on sw2 sw1 and r4
debug eigrp packet query,reply
logging buffered 7
logging buffered 9999
ok now we will shutdown int lo1

r4
------

*Dec 21 21:16:08.171: EIGRP: Enqueueing QUERY on FastEthernet0/0 iidbQ un/rely 0/1
serno 14-14
*Dec 21 21:16:08.175: EIGRP: Sending QUERY on FastEthernet0/0
*Dec 21 21:16:08.175:   AS 1, Flags 0x0, Seq 11/0 idbQ 0/0 iidbQ un/rely 0/0 serno
14-14
*Dec 21 21:16:10.159: %LINK-5-CHANGED: Interface Loopback1, changed state to
administratively down
*Dec 21 21:16:10.711: EIGRP: Received REPLY on FastEthernet0/0 nbr 10.10.4.4
*Dec 21 21:16:10.711:   AS 1, Flags 0x0, Seq 58/11 idbQ 0/0 iidbQ un/rely 0/0 peerQ
un/rely 0/0
*Dec 21 21:16:11.159: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1,
changed state to down
r4#

ok we can see r4 is queryin out looking for the route no other router has a route to
it
sw2
---
we can see sw2 is sending out the query to all it neighbors

:38:48: EIGRP: Enqueueing QUERY on Port-channel2 iidbQ un/rely 0/1 serno 27-27
01:38:48: EIGRP: Enqueueing QUERY on Port-channel8 iidbQ un/rely 0/1 serno 27-27
01:38:48: EIGRP: Enqueueing QUERY on FastEthernet0/4 iidbQ un/rely 0/1 serno 27-27
sw1
----
1:38:51: EIGRP: Received QUERY on Port-channel2 nbr 10.229.254.2
01:38:51:   AS 1, Flags 0x0, Seq 55/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
01:38:51: EIGRP: Enqueueing QUERY on FastEthernet0/5 iidbQ un/rely 0/1 serno 25-25
01:38:51: EIGRP: Enqueueing QUERY on Port-channel7 iidbQ un/rely 0/1 serno 25-25
01:38:51: EIGRP: Enqueueing QUERY on Port-channel2 iidbQ un/rely 0/1 serno 25-25
01:38:51: EIGRP: Received QUERY on Port-channel7 nbr 172.25.11.2
01:38:51:   AS 1, Flags 0x0, Seq 41/0 idbQ 0/0 iidbQ un/rely 0/1 peerQ un/rely 0/0

we can see it is sending and recieving querys

the point is that is wasted pratice as we know that no other router has reachability
to this network
Now on s2
----------
we configuring a summary route for r2 loopbacks this should also act as boundary for
the query

switch2(config-if)#int po8
switch2(config-if)#ip summary-address eigrp 1 10.10.0.0 255.255.248.0

switch2(config-if)#int po2
switch2(config-if)#ip summary-address eigrp 1 10.10.0.0 255.255.248.0

sw1
----
switch1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     169.254.0.0/32 is subnetted, 1 subnets
S       169.254.0.1 is directly connected, Null0
     5.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
S       5.5.5.5/32 is directly connected, FastEthernet0/5
D       5.5.5.0/24 [90/156160] via 10.164.50.1, 00:02:41, FastEthernet0/5
     172.25.0.0/24 is subnetted, 2 subnets
C       172.25.11.0 is directly connected, Port-channel7
D       172.25.10.0 [90/13568] via 172.25.11.2, 00:02:43, Port-channel7
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.10.0.0/21 [90/30720] via 10.229.254.2, 00:01:41, Port-channel2
C       10.229.254.0/24 is directly connected, Port-channel2
C       10.164.50.0/24 is di
we are no longer recieving the loopbacks from r4
we are now only getting the 10.10.0.0/21

ok now on s1 when we shutdown r2 l01

01:55:28: EIGRP: Received QUERY on Port-channel2 nbr 10.229.254.2
01:55:28:   AS 1, Flags 0x0, Seq 73/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
01:55:28: EIGRP: Enqueueing REPLY on Port-channel2 nbr 10.229.254.2 iidbQ un/rely 0/1
peerQ un/rely 0/0 serno 41-41
01:55:28: EIGRP: Sending REPLY on Port-channel2 nbr 10.229.254.2
01:55:28:   AS 1, Flags 0x0, Seq 65/73 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
serno 41-41
we are recieving a query but we just reply we are not sending the query further
upstream. This is because we no longer have 10.10.1.0 in our topology table we only
have the summary route so we are just replying saying the route is unknown
so we have successfully limited the boundary of the query domain by using
summarization

LAB2
-----

Potential problem with summary route to null 0




on sw 1
--------
i have configured a bunch loopback

Loopback0              10.14.0.1       YES manual up                    up
Loopback1              10.14.1.1       YES manual up                    up
Loopback2              10.14.2.1       YES manual up                    up

switch1(config)#router eigrp 1
switch1(config-router)#network 10.14.0.0 0.0.0.255
switch1(config-router)#network 10.14.1.0 0.0.0.255
switch1(config-router)#network 10.14.2.0 0.0.0.255

i am advertising this in eigrp

on sw4
------
i am going send a summary route 0.0.0.0 to sw2

on the link to sw2
switch4(config)#int po9
switch4(config-if)#ip summary eigrp 1 0.0.0.0 0.0.0.0

ok on sw2
---------
switch2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.25.10.2 to network 0.0.0.0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/156160] via 10.10.4.5, 00:15:48, FastEthernet0/4
     5.0.0.0/24 is subnetted, 1 subnets
D       5.5.5.0 [90/158720] via 10.229.254.1, 00:02:49, Port-channel2
     172.25.0.0/24 is subnetted, 2 subnets
D       172.25.11.0 [90/13568] via 10.229.254.1, 00:02:51, Port-channel2
C       172.25.10.0 is directly connected, Port-channel8
     10.0.0.0/24 is subnetted, 6 subnets
D       10.14.0.0 [90/139008] via 10.229.254.1, 00:02:49, Port-channel2
C       10.10.4.0 is directly connected, FastEthernet0/4
D       10.14.1.0 [90/139008] via 10.229.254.1, 00:02:49, Port-channel2
D       10.14.2.0 [90/139008] via 10.229.254.1, 00:02:49, Port-channel2
C       10.229.254.0 is directly connected, Port-channel2
D       10.164.50.0 [90/30720] via 10.229.254.1, 00:02:53, Port-channel2
D*   0.0.0.0/0 [90/21504] via 172.25.10.2, 00:00:53, Port-channel8
switch2#

we have recieved a default route from switch 4
ok on sw2 we will summarize the 10.14.0.0 loopbacks from sw1 to r2
10.14.0.0/22
this will also create 10.164.0.0/22 in the routing table of switch 4 point at null 0
switch2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.25.10.2 to network 0.0.0.0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/156160] via 10.10.4.5, 00:15:48, FastEthernet0/4
     5.0.0.0/24 is subnetted, 1 subnets
D       5.5.5.0 [90/158720] via 10.229.254.1, 00:02:49, Port-channel2
     172.25.0.0/24 is subnetted, 2 subnets
D       172.25.11.0 [90/13568] via 10.229.254.1, 00:02:51, Port-channel2
C       172.25.10.0 is directly connected, Port-channel8
     10.0.0.0/24 is subnetted, 6 subnets
D       10.14.0.0 [90/139008] via 10.229.254.1, 00:02:49, Port-channel2
C       10.10.4.0 is directly connected, FastEthernet0/4
D       10.14.1.0 [90/139008] via 10.229.254.1, 00:02:49, Port-channel2
D       10.14.2.0 [90/139008] via 10.229.254.1, 00:02:49, Port-channel2
C       10.229.254.0 is directly connected, Port-channel2
D       10.164.50.0 [90/30720] via 10.229.254.1, 00:02:53, Port-channel2
D*   0.0.0.0/0 [90/21504] via 172.25.10.2, 00:00:53, Port-channel8
switch2#

Ok now we will shutdown the int 10.14.2.1 on sw1

switch2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.25.10.2 to network 0.0.0.0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/156160] via 10.10.4.5, 00:00:26, FastEthernet0/4
     5.0.0.0/24 is subnetted, 1 subnets
D       5.5.5.0 [90/158720] via 10.229.254.1, 00:00:26, Port-channel2
     172.25.0.0/24 is subnetted, 2 subnets
D       172.25.11.0 [90/13568] via 10.229.254.1, 00:00:26, Port-channel2
C       172.25.10.0 is directly connected, Port-channel8
     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D       10.14.0.0/24 [90/139008] via 10.229.254.1, 00:00:26, Port-channel2
D       10.14.0.0/22 is a summary, 00:00:27, Null0
C       10.10.4.0/24 is directly connected, FastEthernet0/4
D       10.14.1.0/24 [90/139008] via 10.229.254.1, 00:00:27, Port-channel2
C       10.229.254.0/24 is directly connected, Port-channel2
D       10.164.50.0/24 [90/30720] via 10.229.254.1, 00:00:28, Port-channel2
D*   0.0.0.0/0 [90/21504] via 172.25.10.2, 00:

notice 10.14.2.0 is gone out the route table ideally we would want the traffic to go
the default route where it has backup path via sw4
But it is not it is failing
switch2#ping 10.14.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.14.2.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
switch2#
this is because it is choosing the longer prefix match of 10.14.0.0/22 pointing at
the discard route null 0

to get around this we will need to do the following we will mess with the admin
distance on the summary route
on sw4 we will create a summary route for 10.14.0.0/22 with lower admin distance so
it should take precendence over the null route we will set the admin distance on the
initial summary to above 90 so 91

sw4
----
switch4(config)#int port-chan 9
switch4(config-if)#no ip summary-address eigrp 1 10.14.0.0 255.255.252.0 2
so i generated the summary route on interface facing sw2 with admin distance 2


sw2
----
switch2#sh run int fa0/4
Building configuration...
Current configuration : 139 bytes
!
interface FastEthernet0/4
 no switchport
 ip address 10.10.4.4 255.255.255.0
 ip summary-address eigrp 1 10.14.0.0 255.255.252.0 91


Now look at the route table on s2

switch2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.25.10.2 to network 0.0.0.0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/156160] via 10.10.4.5, 00:03:29, FastEthernet0/4
     5.0.0.0/24 is subnetted, 1 subnets
D       5.5.5.0 [90/158720] via 10.229.254.1, 00:23:01, Port-channel2
     172.25.0.0/24 is subnetted, 2 subnets
D       172.25.11.0 [90/13568] via 10.229.254.1, 00:23:01, Port-channel2
C       172.25.10.0 is directly connected, Port-channel8
     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
D       10.14.0.0/24 [90/139008] via 10.229.254.1, 00:23:01, Port-channel2
D       10.14.0.0/22 [90/149504] via 172.25.10.2, 00:00:12, Port-channel8
C       10.10.4.0/24 is directly connected, FastEthernet0/4
D       10.14.1.0/24 [90/139008] via 10.229.254.1, 00:23:02, Port-channel2
C       10.229.254.0/24 is directly connected, Port-channel2
D       10.164.50.0/24 [90/30720] via 10.229.254.1, 00:23:05, Port-channel2
D*   0.0.0.0/0 [90/21504] via 172.25.10.2, 00:00:16, Port-channel8
switch2#

we are now not looking at the null route we have route 10.14.0.0/22 via port
port-channel 8


LAB3
------
Leak Map I will add a link from r4 to sw4


ok so on r4

D       10.14.0.0 [90/156416] via 10.162.62.3, 00:14:48, FastEthernet0/1
D       10.14.1.0 [90/156416] via 10.162.62.3, 00:14:48, FastEthernet0/1

it is picking the route via sw4 - sw1 for both routes
I want to influence this from sw1 to go the other way for 10.164.1.0 using a leak map
and we will 10.14.0.0 going the current way

ok on s1
---------

first thing i am sending a summary route via portchannel 9 to sw1
switch1(config-if)#int po7
switch1(config-if)#ip summary-address eigrp 1 10.14.0.0 255.255.252.0

ok next thing i will do
is create a route-map called leak


switch1(config)#route-map LEAK
switch1(config-route-map)#match ip address prefix LEAK ?
switch1(config-route-map)#match ip address prefix LEAK
switch1(config-route-map)#exit
switch1(config)#ip prefix-list LEAK permit 10.14.1.0/24

ok now i will create a summary route for 10.14.0.0 networks but i will leak 10.14.1.0 via port channel 2 pointing to sw2

switch1(config-if)#ip summary-address eigrp 1 10.14.0.0 255.255.252.0 leak-map LEAK
this would allow 10.164.1.0 to be advertised aswell as the summary as sw2 would be advertising hte more specfic to r4 longest match it would go this way while the other  10.14.0.1/24 would go via sw4

LAB4
-------
4) Lab for stub




r4
---
r4(config)#do sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.229.253.1    YES manual up                    up 
FastEthernet0/1            unassigned      YES TFTP   administratively down down
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Serial0/1/0                unassigned      YES NVRAM  administratively down down
Loopback0                  10.10.9.1       YES manual up                    up 
Loopback1                  4.4.4.4         YES manual up                    up 
r4(config)#

so i am advertising the two loop backs and 10.229.253.0 link subnet on r4

r4#sh run | begin router eigrp 1
router eigrp 1
 network 4.4.4.4 0.0.0.0
 network 10.10.9.0 0.0.0.255
 network 10.229.253.0 0.0.0.255
 no auto-summary
!


sw2
----
switch2#sh ip int brief | inc up
FastEthernet0/4        10.229.253.2    YES manual up                    up
FastEthernet0/13       unassigned      YES NVRAM  up                    up
FastEthernet0/14       unassigned      YES NVRAM  up                    up
FastEthernet0/15       unassigned      YES NVRAM  up                    up
Port-channel2          10.229.254.2    YES NVRAM  up                    up
Loopback0              11.11.11.1      YES manual up                    up
Loopback1              2.2.2.2         YES manual up                    up
switch2#
ok so we are adverising the two link ip and 2 loopbacks on s2
switch2#sh run | begin router eigrp
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 10.229.253.0 0.0.0.255
 network 10.229.254.0 0.0.0.255
 network 11.11.11.0 0.0.0.255
 no auto-summary

sw1
---

switch1(config)#do sh ip int brief | inc up
FastEthernet0/5        10.164.50.2     YES NVRAM  up                    up
FastEthernet0/13       unassigned      YES NVRAM  up                    up
FastEthernet0/14       unassigned      YES NVRAM  up                    up
FastEthernet0/15       unassigned      YES NVRAM  up                    up
Port-channel2          10.229.254.1    YES NVRAM  up                    up
Loopback0              1.1.1.1       YES NVRAM  up                    up
Loopback1              10.14.1.1       YES NVRAM  up                    up
switch1(config)#
so we are adverising the two links and the 2 loopbacks

switch1#sh run | begin router eigrp 1
router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 10.14.1.0 0.0.0.255
 network 10.164.50.0 0.0.0.255
 network 10.229.254.0 0.0.0.255
 no auto-summary
r5
---
r5#sh run | begin router eigrp
router eigrp 1
 network 5.0.0.0
 network 10.0.0.0
 no auto-summary
so we are advertising the link level and the loopback

r5#sh ip int brief | inc up
FastEthernet0/0            10.164.50.1     YES NVRAM  up                    up 
Loopback0                  5.5.5.5         YES NVRAM  up                    up 

ok r4
------
i will put on debug query and reply eigrp packets and i will shutdown 5.5.5.5 network
sw2
---
I will also put on debug query and reply on sw2 same shutdown 5.5.5.5

r4
---
r4#sh log
Syslog logging: enabled (1 messages dropped, 1 messages rate-limited,
                0 flushes, 0 overruns, xml disabled, filtering disabled)
    Console logging: level debugging, 89 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
                     filtering disabled
    Buffer logging: level debugging, 29 messages logged, xml disabled,
                    filtering disabled
    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled
No active filter modules.
    Trap logging: level informational, 32 message lines logged
Log Buffer (6666 bytes):
*Dec 22 21:49:08.707: %SYS-5-CONFIG_I: Configured from console by console
*Dec 22 21:49:34.751: EIGRP: Received QUERY on FastEthernet0/0 nbr 10.229.253.2
*Dec 22 21:49:34.751:   AS 1, Flags 0x0, Seq 20/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Dec 22 21:49:34.763: EIGRP: Enqueueing QUERY on FastEthernet0/0 iidbQ un/rely 0/1 serno 24-24
*Dec 22 21:49:34.767: EIGRP: Sending QUERY on FastEthernet0/0
*Dec 22 21:49:34.767:   AS 1, Flags 0x0, Seq 17/0 idbQ 0/0 iidbQ un/rely 0/0 serno 24-24
*Dec 22 21:49:34.799: EIGRP: Received REPLY on FastEthernet0/0 nbr 10.229.253.2
*Dec 22 21:49:34.799:   AS 1, Flags 0x0, Seq 22/17 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Dec 22 21:49:34.811: EIGRP: Enqueueing REPLY on FastEthernet0/0 nbr 10.229.253.2 iidbQ un/rely 0/1 peerQ un/rely 0/0 serno 25-25
*Dec 22 21:49:34.819: EIGRP: Sending REPLY on FastEthernet0/0 nbr 10.229.253.2
*Dec 22 21:49:34.819:   AS 1, Flags 0x0, Seq 18/22 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 25-25

ok so we can see on r4 we are sending and receing query and replies

ok same on sw2

switch2#sh log
Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)
    Console logging: level debugging, 257 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
                     filtering disabled
    Buffer logging: level debugging, 57 messages logged, xml disabled,
                    filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    File logging: disabled
    Trap logging: level informational, 56 message lines logged
Log Buffer (66666 bytes):
00:59:51: %SYS-5-CONFIG_I: Configured from console by console
01:01:11: EIGRP: Received QUERY on Port-channel2 nbr 10.229.254.1
01:01:11:   AS 1, Flags 0x0, Seq 49/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
01:01:11: EIGRP: Enqueueing QUERY on FastEthernet0/4 iidbQ un/rely 0/1 serno 15-15
01:01:11: EIGRP: Enqueueing QUERY on Port-channel2 iidbQ un/rely 0/1 serno 15-15
01:01:11: EIGRP: Sending QUERY on FastEthernet0/4 >>>>> sending query to r4
01:01:11:   AS 1, Flags 0x0, Seq 20/0 idbQ 0/0 iidbQ un/rely 0/0 serno 15-15
01:01:11: EIGRP: Sending QUERY on Port-channel2
01:01:11:   AS 1, Flags 0x0, Seq 21/0 idbQ 0/0 iidbQ un/rely 0/0 serno 15-15
01:01:11: EIGRP: Received QUERY on FastEthernet0/4 nbr 10.229.253.1
01:01:11:   AS 1, Flags 0x0, Seq 17/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
01:01:11: EIGRP: Enqueueing REPLY on FastEthernet0/4 nbr 10.229.253.1 iidbQ un/rely 0/1 peerQ un/rely 0/0 serno 16-16
01:01:11: EIGRP: Received REPLY on Port-channel2 nbr 10.229.254.1
01:01:11:   AS 1, Flags 0x0, Seq 50/21 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
01:01:11: EIGRP: Sending REPLY on FastEthernet0/4 nbr 10.229.253.1
01:01:11:   AS 1, Flags 0x0, Seq 22/17 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 16-16
01:01:11: EIGRP: Received REPLY on FastEthernet0/4 nbr 10.229.253.1
01:01:11:   AS 1, Flags 0x0, Seq 18/22 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
01:01:11: EIGRP: Enqueueing REPLY on Port-channel2 nbr 10.229.254.1 iidbQ un/rely 0/1 peerQ un/rely 0/0 serno 17-17
01:01:11: EIGRP: Sending REPLY on Port-channel2 nbr 10.229.254.1
01:01:11:   AS 1, Flags 0x0, Seq 23/50 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 17-17

Right now on r4 i will configure it as stub network

r4(config-if)#router eigrp 1
r4(config-router)#eigrp stub?
stub
r4(config-router)#eigrp stub ?
  connected      Do advertise connected routes
  leak-map       Allow dynamic prefixes based on the leak-map
  receive-only   Set IP-EIGRP as receive only neighbor
  redistributed  Do advertise redistributed routes
  static         Do advertise static routes
  summary        Do advertise summary routes
  <cr>
r4(config-router)#eigrp stub
r4(config-router)#

i will take the defaults which are connected and summary advertisements only

r4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/158720] via 10.229.253.2, 00:01:02, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/156160] via 10.229.253.2, 00:01:02, FastEthernet0/0
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback1
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D       10.14.1.0/24 [90/158720] via 10.229.253.2, 00:01:02, FastEthernet0/0
C       10.10.9.1/32 is directly connected, Loopback0
D       10.229.254.0/24 [90/30720] via 10.229.253.2, 00:01:02, FastEthernet0/0
C       10.229.253.0/24 is directly connected, FastEthernet0/0
D       10.164.50.0/24 [90/33280] via 10.229.253.2, 00:01:02, FastEthernet0/0
     11.0.0.0/32 is subnetted, 1 subnets
D       11.11.11.1 [90/156160] via 10.229.253.2, 00:01:04, FastEthernet0/0
r4#

i am still recieving all the routes

r4#sh log
Syslog logging: enabled (1 messages dropped, 1 messages rate-limited,
                0 flushes, 0 overruns, xml disabled, filtering disabled)
    Console logging: level debugging, 456 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
                     filtering disabled
    Buffer logging: level debugging, 396 messages logged, xml disabled,
                    filtering disabled
    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled
No active filter modules.
    Trap logging: level informational, 35 message lines logged
Log Buffer (6666 bytes):
*Dec 22 22:02:04.851: EIGRP: Enqueueing QUERY on FastEthernet0/0 iidbQ un/rely 0/1 serno 33-33
*Dec 22 22:02:04.855: EIGRP: Sending QUERY on FastEthernet0/0
*Dec 22 22:02:04.855:   AS 1, Flags 0x0, Seq 23/0 idbQ 0/0 iidbQ un/rely 0/0 serno 33-33
*Dec 22 22:02:04.887: EIGRP: Received REPLY on FastEthernet0/0 nbr 10.229.253.2
*Dec 22 22:02:04.887:   AS 1, Flags 0x0, Seq 33/23 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
r4#



switch2#sh log
Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)
    Console logging: level debugging, 303 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
                     filtering disabled
    Buffer logging: level debugging, 103 messages logged, xml disabled,
                    filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    File logging: disabled
    Trap logging: level informational, 58 message lines logged
Log Buffer (66666 bytes):
01:13:41: EIGRP: Received QUERY on Port-channel2 nbr 10.229.254.1
01:13:41:   AS 1, Flags 0x0, Seq 59/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
01:13:41: EIGRP: Enqueueing REPLY on Port-channel2 nbr 10.229.254.1 iidbQ un/rely 0/1 peerQ un/rely 0/0 serno 23-23
01:13:41: EIGRP: Sending REPLY on Port-channel2 nbr 10.229.254.1
01:13:41:   AS 1, Flags 0x0, Seq 30/59 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 23-23
01:13:41: EIGRP: Received QUERY on FastEthernet0/4 nbr 10.229.253.1
01:13:41:   AS 1, Flags 0x0, Seq 23/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
01:13:41: EIGRP: Enqueueing REPLY on FastEthernet0/4 nbr 10.229.253.1 iidbQ un/rely 0/1 peerQ un/rely 0/0 serno 25-25
01:13:41: EIGRP: Sending REPLY on FastEthernet0/4 nbr 10.229.253.1
01:13:41:   AS 1, Flags 0x0, Seq 33/23 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 25-25
switch2#
s2 is no longer querying r4 for the route it recieved a query for the route and generated a reply but it do not initially send the query onto r4 so we have successfull limited the boundary domain

now we will step it up a bit we will move r5 to directly connect r4 not connecting to s1 so it is futher downstream r4 and r4 is a transit for it also as above r4 is a stub
so the topology will be


r4
---
r4(config)#int s0/1/0
r4(config-if)#ip address 11.11.11.1 255.255.255.0
r4(config-if)#no shut
r4(config-if)#exit
r4(config)#router eigrp 1
r4(config-router)#
*Dec 22 22:07:03.931: %LINK-3-UPDOWN: Interface Serial0/1/0, changed state to down
r4(config-router)#network 11.11.11.0 0.0.0.255
r4(config-router)#

r5
---
r5(config-if)#do sh ip int brief | inc up
Serial0/1/0                11.11.11.2      YES manual up                    up 
Loopback0                  5.5.5.5         YES NVRAM  up                    up 
Loopback2                  12.12.12.12     YES manual up                    up 
r5(config-if)#

r5(config)#do sh run | begin router eigrp 1
router eigrp 1
 network 5.5.5.5 0.0.0.0
 network 11.11.11.0 0.0.0.255
 network 12.12.12.0 0.0.0.255
 no auto-summary
!

ok lets look at the results

r5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/2297856] via 11.11.11.1, 00:01:43, Serial0/1/0
     5.0.0.0/24 is subnetted, 1 subnets
C       5.5.5.0 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       10.10.9.1/32 [90/2297856] via 11.11.11.1, 00:01:43, Serial0/1/0
D       10.229.253.0/24 [90/2172416] via 11.11.11.1, 00:01:43, Serial0/1/0
     11.0.0.0/24 is subnetted, 1 subnets
C       11.11.11.0 is directly connected, Serial0/1/0
     12.0.0.0/32 is subnetted, 1 subnets
C       12.12.12.12 is directly connected, Loopback2
r5#

i seem to be missing routes where is like sw2 loopback 2.2.2.2 or sw 1 loopback 1.1.1.1

i do have all expected routes in r4 routing table

r4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/158720] via 10.229.253.2, 00:27:04, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/156160] via 10.229.253.2, 00:27:04, FastEthernet0/0
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback1
     5.0.0.0/24 is subnetted, 1 subnets
D       5.5.5.0 [90/2297856] via 11.11.11.2, 00:03:19, Serial0/1/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D       10.14.1.0/24 [90/158720] via 10.229.253.2, 00:27:04, FastEthernet0/0
C       10.10.9.1/32 is directly connected, Loopback0
D       10.229.254.0/24 [90/30720] via 10.229.253.2, 00:27:04, FastEthernet0/0
C       10.229.253.0/24 is directly connected, FastEthernet0/0
D       10.164.50.0/24 [90/33280] via 10.229.253.2, 00:27:08, FastEthernet0/0
     11.0.0.0/24 is subnetted, 1 subnets
C       11.11.11.0 is directly connected, Serial0/1/0
     12.0.0.0/32 is subnetted, 1 subnets
D       12.12.12.12 [90/2297856] via 11.11.11.2, 00:03:23, Serial0/1/0
r4#

let look at sw2
----------------
switch2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/139008] via 10.229.254.1, 00:41:42, Port-channel2
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback1
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/156160] via 10.229.253.1, 00:28:40, FastEthernet0/4
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D       10.14.1.0/24 [90/139008] via 10.229.254.1, 00:53:56, Port-channel2
D       10.10.9.1/32 [90/156160] via 10.229.253.1, 00:28:40, FastEthernet0/4
C       10.229.254.0/24 is directly connected, Port-channel2
C       10.229.253.0/24 is directly connected, FastEthernet0/4
D       10.164.50.0/24 [90/30720] via 10.229.254.1, 00:53:56, Port-channel2
D       11.11.11.0/24 [90/2172416] via 10.229.253.1, 00:12:23, FastEthernet0/4
switch2#
i am not seeing 5 loopback 5.5.5.5 i am seeing doing 11.11.11.0/24 network this as it is connected to r4 and r4 advertises connected or summary routes to sw2

ok what i can do to resolve this is to use a leak map on r2 for my stub
ok firstly i will create a prefix list matching 2. and 5. subnets

r4(config)#ip prefix-list LEAK permit 5.5.5.0/24
r4(config)#ip prefix-list LEAK permit 2.2.2.2/32
now create a route map to bring the 2 prefix list togther
r4(config)#route-map LEAK
r4(config-route-map)#match ip address prefix LEAK

I will now apply using a leak map
r4(config)#router eigrp 1
r4(config-router)#eigrp stub leak-map LEAK

this will effectively allow 5.5.5.5 to be advertised to the s2 side of the network
and 2.2.2.2 to be advertised to the r5 side of the network

we now have a route to 2.2.2.2 on r5
r5#sh ip route 2.2.2.2
Routing entry for 2.2.2.2/32
  Known via "eigrp 1", distance 90, metric 2300416, type internal
  Redistributing via eigrp 1
  Last update from 11.11.11.1 on Serial0/1/0, 00:04:53 ago
  Routing Descriptor Blocks:
  * 11.11.11.1, from 11.11.11.1, 00:04:53 ago, via Serial0/1/0
      Route metric is 2300416, traffic share count is 1
      Total delay is 25100 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

and on s2 a route to 5.5.5.5
switch2#sh ip route 5.5.5.5
Routing entry for 5.5.5.0/24
  Known via "eigrp 1", distance 90, metric 2300416, type internal
  Redistributing via eigrp 1
  Last update from 10.229.253.1 on FastEthernet0/4, 00:05:56 ago
  Routing Descriptor Blocks:
  * 10.229.253.1, from 10.229.253.1, 00:05:56 ago, via FastEthernet0/4
      Route metric is 2300416, traffic share count is 1
      Total delay is 25100 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2
switch2#

switch2#ping 5.5.5.5 source 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet sent with a source address of 2.2.2.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
switch2#

No comments:

Post a Comment