Thursday, December 22, 2011

EIGRP DEFAULT ROUTING

EIGRP DEFAULT ROUTING
we have a few options with default routing in eigrp we could use
* we could use ip default-network "network"
* we could use native advertisements of the 0.0.0.0./0 prefix
* default-information command

With the default information originate command it acts differently it eigrp this
command is used to specify what you will do we a default route rather than generate
one. So for example if you say no default-information originate it means you will
reject a default route if sent to you,
if you said
no default information out it means if you learn a default route you will not
advertise it out

IP Default Network
-------------------
This concept for default routing was brought about for mainly IGRP compatability.
IGRP will not accept routes of 0.0.0.0/0 it does not comprehend that as  default
route. So default network was brought in. It is quite restrictive the following
criteria must be met
the default-network must be
  - dynamically learned through EIGRP
  - Not directly connected
  -a classfull network
So it has limited application in modern networks

An example you have a sp router sending a few networks to your ce router you might
mark one of this networks as a default route  and it will be sent through your
interior routing domain as candidate default route it get over the issue of igrp not
been able to understand you sending 0.0.0.0/0. It is legacy at this stage

Advertising 0.0.0.0/0
----------------------
we could advertise this in 3 ways
1) static default route point to ip route 0.0.0.0 0.0.0.0 to put the route in the
table and then do a network 0.0.0.0 255.255.255.255
2) redistribution- we could do the above static route but instead of using the
network command redistribute the static in to eigrp the only difference here is tha
it will come in at higher admin disstance as it is a eigrp external route vs eigrp
internal route
3)We can summarize on the interface a summary route. For example on the interface do
a ip summary address eigrp 1 0.0.0.0 0.0.0.0

For the LAB
------------
r4 connects to sw2 which has a single connection sw4 which has a connection to sw1
which connects to r5
we will do firstly default network then static default route with eigrp advertising a
redistributed eigrp network and a summary route






Lab1 Default NETWORK
---------------------
ok so r4 is running rip with sw2 fa0/4 interface sw2 connects to sw1 which connects
to r5
sw2 will redistribute a prefix learnt from r4 (4.4.4.4) and we will mark it as a
default network to the rest of the eigrp domain

r4
---
r4(config)#do sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.229.253.1    YES manual up                    up 
FastEthernet0/1            unassigned      YES TFTP   administratively down down
Serial0/0/0                unassigned      YES NVRAM  administratively down down
Serial0/1/0                unassigned      YES TFTP   administratively down down
Loopback0                  10.10.9.1       YES manual up                    up 
Loopback1                  4.4.4.4         YES manual up                    up 
r4(config)#router rip
r4(config-router)#version 2
r4(config-router)#no auto
r4(config-router)#network 10.229.253.0
r4(config-router)#network 4.4.4.4 0.0.0.0


sw2
----
switch2#sh ip int brief | inc up
FastEthernet0/4        10.229.253.2    YES manual up                    up
FastEthernet0/13       unassigned      YES NVRAM  up                    up
FastEthernet0/14       unassigned      YES NVRAM  up                    up
FastEthernet0/15       unassigned      YES NVRAM  up                    up
Port-channel2          10.229.254.2    YES NVRAM  up                    up
Loopback1              2.2.2.2         YES manual up                    up
switch2#
switch2(config)#router rip
switch2(config-router)#network 10.229.253.0
switch2(config-router)#version 2
switch2(config-router)#no auto
switch2(config-router)#
router eigrp 1
 network 10.229.254.0 0.0.0.255
 no auto-summary
redistribute rip metric 100 100 100 100 100

in global config
switch2(config)#ip default-network 4.4.4.0
switch2(config)#
ok so in the above i redistribute rip into eigrp this will bring the 4.4.4.4 network
into the eigrp domain i also setting this as default network

ok sw1 and r5 are in the eigrp domain lets look what the above config has on there
routing table
ok it is not working the problem is that it is not classfull so breaks the rules the
4.4.4.4 network
so what i have done is on rip changed it to v1 and summary now i am recieving
4.0.0.0/8
switch2(config)#ip default-network 4.0.0.0
switch2(config)#


switch1(config)#exit
switch1#sh ip ro
02:33:56: %SYS-5-CONFIG_I: Configured from console by consoleute
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.229.254.2 to network 4.0.0.0
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     169.254.0.0/32 is subnetted, 1 subnets
S       169.254.0.1 is directly connected, Null0
     4.0.0.0/8 is subnetted, 1 subnets
D*EX    4.0.0.0 [170/25628160] via 10.229.254.2, 00:02:05, Port-channel2
     5.0.0.0/32 is subnetted, 1 subnets
S       5.5.5.5 is directly connected, FastEthernet0/5
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.14.1.0/24 is directly connected, Loopback1
D EX    10.10.9.1/32 [170/25628160] via 10.229.254.2, 00:17:52, Port-channel2
C       10.229.254.0/24 is directly connected, Port-channel2
D EX    10.229.253.0/24
           [170/25628160] via 10.229.254.2, 00:17:52, Port-channel2
C       10.164.50.0/24 is directly connected, FastEthernet0/5
switch1#
now we have default route set via 4.0.0.0 in rip domain

r5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.164.50.2 to network 4.0.0.0
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/156160] via 10.164.50.2, 00:13:30, FastEthernet0/0
     4.0.0.0/8 is subnetted, 1 subnets
D*EX    4.0.0.0 [170/25630720] via 10.164.50.2, 00:02:57, FastEthernet0/0
     5.0.0.0/24 is subnetted, 1 subnets
C       5.5.5.0 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D       10.14.1.0/24 [90/156160] via 10.164.50.2, 00:13:30, FastEthernet0/0
D EX    10.10.9.1/32 [170/25630720] via 10.164.50.2, 00:13:30, FastEthernet0/0
D       10.229.254.0/24 [90/30720] via 10.164.50.2, 00:13:30, FastEthernet0/0
D EX    10.229.253.0/24
           [170/25630720] via 10.164.50.2, 00:13:30, FastEthernet0/0
C       10.164.50.0/24 is directly connected, FastEthernet0/0
     12.0.0.0/32 is subnetted, 1 subnets
C       12.12.12.12 is directly connected, Loopback2
r5#
same on r5 ok so lets try ping a the other loopback on r4 which was not advertised so
we do not have the route
first i will put a reply static route on r4 so it knows how to get back to r5

r5#ping 10.10.9.1 source 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.9.1, timeout is 2 seconds:
Packet sent with a source address of 5.5.5.5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r5#

i can ping a route not advertised in rip or eigrp on r4 from r5 so it is working


LAB 2
------
OK same lab setup but this we will advertise a default route using network statement
and ip route on sw2

ok on
sw2
-----
switch2(config)#no ip default-network 4.0.0.0
switch2(config)#ip route 0.0.0.0 0.0.0.0 fa0/4
switch2(config)#router eigrp 1
switch2(config-router)#network 0.0.0.0
switch2(config-router)#

ok on r5
---------
r5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.164.50.2 to network 0.0.0.0
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/156160] via 10.164.50.2, 00:28:09, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/158720] via 10.164.50.2, 00:00:54, FastEthernet0/0
     4.0.0.0/8 is subnetted, 1 subnets
D EX    4.0.0.0 [170/25630720] via 10.164.50.2, 00:01:41, FastEthernet0/0
     5.0.0.0/24 is subnetted, 1 subnets
C       5.5.5.0 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D       10.14.1.0/24 [90/156160] via 10.164.50.2, 00:28:09, FastEthernet0/0
D EX    10.10.9.1/32 [170/25630720] via 10.164.50.2, 00:28:09, FastEthernet0/0
D       10.229.254.0/24 [90/30720] via 10.164.50.2, 00:28:09, FastEthernet0/0
D       10.229.253.0/24 [90/33280] via 10.164.50.2, 00:00:53, FastEthernet0/0
C       10.164.50.0/24 is directly connected, FastEthernet0/0
     12.0.0.0/32 is subnetted, 1 subnets
C       12.12.12.12 is directly connected, Loopback2
D*   0.0.0.0/0 [90/33280] via 10.164.50.2, 00:00:59, FastEthernet0/0


r5#ping 10.10.9.1 source 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.9.1, timeout is 2 seconds:
Packet sent with a source address of 5.5.5.5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r5#
ok so this alternative solution for a default route
LAB3
-----
Another alternate solution is to redistribute the static
instead of advertising on s2
switch2(config)#router eigrp 1
switch2(config-router)#no network 0.0.0.0 0.0.0.0
switch2(config-router)#redistribute static metric 100 100 100 100 100
r5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.164.50.2 to network 0.0.0.0
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/156160] via 10.164.50.2, 00:05:48, FastEthernet0/0
D EX 4.0.0.0/8 [170/25630720] via 10.164.50.2, 00:05:48, FastEthernet0/0
     5.0.0.0/24 is subnetted, 1 subnets
C       5.5.5.0 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D       10.14.1.0/24 [90/156160] via 10.164.50.2, 00:05:48, FastEthernet0/0
D EX    10.10.9.1/32 [170/25630720] via 10.164.50.2, 00:05:48, FastEthernet0/0
D       10.229.254.0/24 [90/30720] via 10.164.50.2, 00:05:48, FastEthernet0/0
D EX    10.229.253.0/24
           [170/25630720] via 10.164.50.2, 00:01:42, FastEthernet0/0
C       10.164.50.0/24 is directly connected, FastEthernet0/0
     12.0.0.0/32 is subnetted, 1 subnets
C       12.12.12.12 is directly connected, Loopback2
D*EX 0.0.0.0/0 [170/25630720] via 10.164.50.2, 00:00:29, FastEthernet0/0
r5#

r5#ping 10.10.9.1 source 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.9.1, timeout is 2 seconds:
Packet sent with a source address of 5.5.5.5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r5#
notice difference here it is a ex route in the rib with admin distance of 170

No comments:

Post a Comment