Wednesday, December 7, 2011

PPP OVER FRAME RELAY AND PPPOE

PPP Frame-Relay

  • The reason you want to use PPP over frame relay is to make use of the PPP features of authentication,multilink,fragementation etc in frame relay which do not natively support them
  • Configured with virtual template
  • For the additionals features through ppp like authentication you apply to the virtual template interface
  • FR--PPP-IP-TCP-Psyload  would be packet layout
  • We do not have to assign the virtual template as ppp it is assumed
Commands

interface virtual-template 1
ip address 10.229.254.1 255.255.255.0 creating virtual template interface

int s0/0/0
encap frame-relay
int s0/0/0.1
frame-realy interface-dlci 504 ppp virtual-template 1 -applying the virtual template to the interface


LAB PPPOFR

SO i configured ppp over frame relay between 2 routers 
so the dlci are r4 is using 405 r5 is using 504
So basically the first thing that is require is you configure a virtual template
interface Virtual-Template1
 ip address 10.229.254.1 255.255.255.0
there is no need for encap ppp virtual template is for ppp so the only encap is ppp also you assign the ip address here
next you need to apply the virtual template to frame-relay interface
interface Serial0/0/0
 no ip address
 encapsulation frame-relay

int Serial0/0/0.1 point-to-point
frame-relay interface-dlci 504 ppp Virtual-Template1
end

the virtual template number needs to match the created virtual template
the same config has to be done on r4

when i apply the config r4
r5#ping 10.229.254.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.229.254.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/64/68 ms
r5#

There is no entrys in the frame-relay map
r5#sh frame-relay map
r5#

r5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.229.254.1/32 is directly connected, Virtual-Access2
C       10.229.254.0/24 is directly connected, Virtual-Access2

there is peer neighbor route as per normal ppp
A point to note even though this is configured on the main interface which is typically multipoint. The logical instance of the connection is p2p by definition ppp can only run over p2p links
PPP Over Frame Relay packet is broken down as follows
FR-PPP-IP-TCP-PAYLOAD

For the features of ppp you apply them to the int virtaul-template 1 like authentication etc

PPPOE

From IETF

   "Modern access technologies are faced with several conflicting goals.
   It is desirable to connect multiple hosts at a remote site through
   the same customer premise access device.  It is also a goal to
   provide access control and billing functionality in a manner similar
   to dial-up services using PPP.  In many access technologies, the most
   cost effective method to attach multiple hosts to the customer
   premise access device, is via Ethernet.  In addition, it is desirable
   to keep the cost of this device as low as possible while requiring
   little or no configuration."

  • Ethernet was desirable for dsl connections as of the above but the problems with inherit with lack of features such as authentication. Also issue with billing etc was ruling it out. PPOE allowed ppp features to be used over ethernet
  • In order to make a point to point connection over a broadcast segment we use a client server concept
  • For each session we end up with a unique session id and p2p connection over ethernet where features such authentication and billing etc are possibilty
  • The Client sends a PADI(discovery message on the broadcast segment) if there is PPOE Server on the segment it will respond with a PADO(which is basically an offer)  to clients mac.The client will select one offer to respond to with a request packet. Then the server will finish the process with a PADs which is confirmation
  • In the dsl implementation the pppoe client are the singular dsl modem each dsl modem connects into a dsl aggregation multiplexer (dslarm) this does layer 1 briding of all the connections into a large singular connection typical something like a OC48 which connects to the pppoe server which is the agregation router. Then it out to the internet.
  • requires cef
  • use bba broadband access group
  • client config uses a dialer logic
  • Ethernet has mtu of 1500 ppp adds 8 bytes we should set the client dialer int to mtu of 1492 so it will fragement frames over 1492 so we do not go over the ethernet mtu
Commands
Server

int virtual-template 1
ip address 10.221.254.1 255.255.255.0 - we apply ppp features to the virtual template

bba-group pppoe "Name of Group"
virtual-template 1

interface fa0/0
no ip address
pppoe enable group "Name of Group"

Client

Interface dialer 1
ip address 10.165.48.11 255.255.255.0
encap ppp
dialer poool 1
dialer idle-timeout 0
dialer persisent
ip mtu 1492

int fa0/0
pppoe enable group global
pppoe-client client diale-pool-number 1



LAB

The virtual template is created
The broad band acess group (bba) references the virtual template
then the bba group is referenced on the interface
Firstly i will configure the server on
so on r5
interface Virtual-Template5
 ip address 10.164.48.3 255.255.255.0
!

bba-group pppoe EOGHAN
 virtual-template 5

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 pppoe enable group EOGHAN
end

so that is the server configured now to config the client
The client use a dial in logic. You need to use the dialer interface. So you could in actual fact specify interesting traffic to bring up the line.General for constant connections you just say dialer persistent. If you wanted to configure dial on demand you woud us the dialer group this type dial demand is not on the focus of the ccie so i will just dialer persistent

interface Dialer1
 ip address 10.164.48.11 255.255.255.0
 encapsulation ppp
 dialer pool 2
 dialer idle-timeout 0
 dialer persistent
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 2

r1#ping 10.164.48.3 size 1492
Type escape sequence to abort.
Sending 5, 1492-byte ICMP Echos to 10.164.48.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
it is pinging successfully
but if i slightly increase the packet size it no longer pings
r1#ping 10.164.48.3 size 1493
Type escape sequence to abort.
Sending 5, 1493-byte ICMP Echos to 10.164.48.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r1#

ethernet has a mtu of 1500 limit the size of packet minus ppp 1493 ppp adds 8 bytes bringing over the limit in order to allow fragmentation

r1(config)#int dial 1
r1(config-if)#ip mtu 1492
r1(config-if)#exit
add mtu under the dial interface this will fragement ppp packets over 1492

r1#ping 10.164.48.3 size 1493
Type escape sequence to abort.
Sending 5, 1493-byte ICMP Echos to 10.164.48.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms
r1#
allowing the ping

No comments:

Post a Comment