Friday, December 23, 2011

EIGRP ROUTER ID

EIGRP ROUTER ID
EIGRP router id is for a sole purpose of loop prevention with regard to external routes
What could occur is the protocol i am redistributing has a higher admin distance than
the eigrp external routes.So we could possible end up with route feedback.

With internal routes loops are prevented with the dual algorithm the issue with
external routes is the originator metric is not clear  we are effectively breaking the loop prevention when we redistributes

so we could potentially be in case for routing loops this is why we use the router id the idea being that is if
recieve an external route with my router id as the  originator i will reject the
route.
Router id is auto selected with ip of highest loopback or if no loopback highest ip
on interface same as ospf
You can also manual assign with the command
router eigrp 1
eigrp route-d "ip address"
Where you could potential run int issues with this is if you have duplicate route ids

sh ip eigrp top- will allow you to see the route id

lab
----
   


sw4
----
switch4(config)#do sh ip int brief | inc up
FastEthernet0/13       unassigned      YES NVRAM  up                    up
FastEthernet0/14       unassigned      YES NVRAM  up                    up
FastEthernet0/15       unassigned      YES NVRAM  up                    up
FastEthernet0/16       unassigned      YES NVRAM  up                    up
FastEthernet0/17       unassigned      YES NVRAM  up                    up
FastEthernet0/18       unassigned      YES NVRAM  up                    up
Port-channel9          172.25.10.2     YES NVRAM  up                    up
Port-channel10         172.25.11.2     YES NVRAM  up                    up
Loopback0              4.4.4.4         YES manual up                    up
switch4(config)#
router eigrp 1
 network 4.4.4.4 0.0.0.0
 network 172.25.10.0 0.0.0.255
 network 172.25.11.0 0.0.0.255
 no auto-summary

sw2
----
switch2#sh ip int brief | inc up
FastEthernet0/4        10.10.4.4       YES NVRAM  up                    up
FastEthernet0/13       unassigned      YES NVRAM  up                    up
FastEthernet0/14       unassigned      YES NVRAM  up                    up
FastEthernet0/15       unassigned      YES NVRAM  up                    up
FastEthernet0/19       unassigned      YES NVRAM  up                    up
FastEthernet0/20       unassigned      YES NVRAM  up                    up
FastEthernet0/21       unassigned      YES NVRAM  up                    up
Port-channel2          10.229.254.2    YES NVRAM  up                    up
Port-channel8          172.25.10.1     YES NVRAM  up                    up
Loopback0              2.2.2.2         YES manual up                    up
switch2#

switch2#sh run | begin router ei
router eigrp 1
 network 10.229.254.0 0.0.0.255
 network 172.25.10.0 0.0.0.255
 network 2.2.2.2.2   0.0.0.0
 no auto-summary
switch2(config)#router rip
switch2(config-router)#version 2
switch2(config-router)#no auto
switch2(config-router)#network 10.10.4.0  >>> to distribute external routes into     
                                        eigrp

r4
----
r4#sh ip int brief | inc up
FastEthernet0/0            10.10.4.1       YES manual up                    up 
Loopback0                  20.20.20.1      YES manual up                    up 
Loopback1                  30.30.30.1      YES manual up                    up 
Loopback2                  40.40.40.1      YES manual up                    up 
r4#


r4(config)#router rip
r4(config-router)#version 2
r4(config-router)#no auto
r4(config-router)#network 20.20.20.0
r4(config-router)#network 30.30.30.0
r4(config-router)#network 40.40.40.0
r4(config-router)#network 10.10.4.0
r4(config-router)#

sw1
---


switch1(config)#do sh ip int brief | inc up
FastEthernet0/5        unassigned      YES unset  up                    up
FastEthernet0/13       unassigned      YES NVRAM  up                    up
FastEthernet0/14       unassigned      YES NVRAM  up                    up
FastEthernet0/15       unassigned      YES NVRAM  up                    up
FastEthernet0/19       unassigned      YES NVRAM  up                    up
FastEthernet0/20       unassigned      YES NVRAM  up                    up
FastEthernet0/21       unassigned      YES NVRAM  up                    up
Port-channel2          10.229.254.1    YES NVRAM  up                    up
Port-channel7          172.25.11.1     YES NVRAM  up                    up
Loopback0              1.1.1.1         YES manual up                    up
switch1(config)#

router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 10.229.254.0 0.0.0.255
 network 172.25.11.0 0.0.0.255
 no auto-summary
!

We will look at the routing table on

sw4
----
switch4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/136704] via 172.25.11.1, 00:02:07, Port-channel10
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/139008] via 172.25.10.1, 00:02:04, Port-channel9
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
     172.25.0.0/24 is subnetted, 2 subnets
C       172.25.11.0 is directly connected, Port-channel10
C       172.25.10.0 is directly connected, Port-channel9
     10.0.0.0/24 is subnetted, 2 subnets
D       10.10.4.0 [90/30720] via 172.25.10.1, 00:02:04, Port-channel9
D       10.229.254.0 [90/11264] via 172.25.11.1, 00:02:07, Port-channel10
switch4#

sw1
---
switch1(config-router)#exit
switch1(config)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/139008] via 10.229.254.2, 00:02:48, Port-channel2
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/139008] via 172.25.11.2, 00:02:45, Port-channel7
     172.25.0.0/24 is subnetted, 2 subnets
C       172.25.11.0 is directly connected, Port-channel7
D       172.25.10.0 [90/13568] via 172.25.11.2, 00:02:48, Port-channel7
     10.0.0.0/24 is subnetted, 2 subnets
D       10.10.4.0 [90/30720] via 10.229.254.2, 00:02:48, Port-channel2
C       10.229.254.0 is directly connected, Port-channel2
switch1(config)#

Ok so thats all the base config setup so know i will generate a duplicate router id
with no external routes firstly so on sw1
router eigrp 1
switch1(config-router)#eigrp router-id 7.7.7.7

sw4
---

switch4(config)#router eigrp 1
switch4(config-router)#eigrp router-id 7.7.7.7
switch4(config-router)#

switch4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/136704] via 172.25.11.1, 00:02:08, Port-channel10
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/139008] via 172.25.10.1, 00:02:08, Port-channel9
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
     172.25.0.0/24 is subnetted, 2 subnets
C       172.25.11.0 is directly connected, Port-channel10
C       172.25.10.0 is directly connected, Port-channel9
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback1
     10.0.0.0/24 is subnetted, 2 subnets
D       10.10.4.0 [90/30720] via 172.25.10.1, 00:02:08, Port-channel9
D       10.229.254.0 [90/11264] via 172.25.11.1, 00:02:09, Port-channel10
switch4#

ok so no affect the route id being duplicate makes no affect on internal routes

ok on
sw2
---
switch2(config)#router eigrp 1
switch2(config-router)#redistribute rip metric 100 100 100 100 100
switch2(config-router)#

ok i am just realising something here this not going to work
The reason being that the process looks at the originator id which is sw2 so it will
make no difference in this particular example if sw1 and sw4 have duplicates as sw1
is the one advertising the external routes
switch1#sh ip eigrp top 20.20.20.1/32
IP-EIGRP (AS 1): Topology entry for 20.20.20.1/32
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 25628160
  Routing Descriptor Blocks:
  10.229.254.2 (Port-channel2), from 10.229.254.2, Send flag is 0x0
      Composite metric is (25628160/25625600), Route is External
      Vector metric:
        Minimum bandwidth is 100 Kbit
        Total delay is 1100 microseconds
        Reliability is 100/255
        Load is 100/255
        Minimum MTU is 100
        Hop count is 1
      External data:
        Originating router is 1.1.1.1
        AS number of route is 0
        External protocol is RIP, external metric is 1
        Administrator tag is 0 (0x00000000)
switch1#
if you look at the originator id it is sw2 router id  i gave it

so now i will give sw2 the same 7.7.7.7 eigrp router id

switch2(config)#router eigrp 1
switch2(config-router)#eigrp router-id 7.7.7.7
switch2(config-router)#

now on sw1
-----------
switch1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/139008] via 10.229.254.2, 00:00:09, Port-channel2
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/139008] via 172.25.11.2, 00:27:40, Port-channel7
     172.25.0.0/24 is subnetted, 1 subnets
C       172.25.11.0 is directly connected, Port-channel7
     7.0.0.0/32 is subnetted, 1 subnets
C       7.7.7.7 is directly connected, Loopback11
     10.0.0.0/24 is subnetted, 2 subnets
D       10.10.4.0 [90/30720] via 10.229.254.2, 00:00:10, Port-channel2
C       10.229.254.0 is directly connected, Port-channel2
switch1#

the external route are gone

switch1#sh ip eigrp event
Event information for AS 1:
1    01:40:58.395 Change queue emptied, entries: 2
2    01:40:58.395 Ignored route, metric: 40.40.40.1 25628160
3    01:40:58.395 Ignored route, neighbor info: 10.229.254.2 Port-channel7
4    01:40:58.395 Ignored route, dup router: 7.7.7.7
5    01:40:58.395 Ignored route, metric: 30.30.30.1 25628160
6    01:40:58.395 Ignored route, neighbor info: 10.229.254.2 Port-channel7
7    01:40:58.395 Ignored route, dup router: 7.7.7.7

i am seeing ignored routes from duplicate id 7.7.7.7
so as the orignator router id (router doing the redistribution) is duplicate it is
not accepting the external routes notice it does still allow internal routes this is
solely for external redistributed routes as loop prevention as dual will deal with
the internal.
The eigrp router id does not have to be an active interface or advertised in eigrp

1 comment:

  1. >>originator id which is sw2
    in output: Originating router is 1.1.1.1

    but loopback on Sw2 is 2.2.2.2

    Oooops...

    ReplyDelete