Friday, December 30, 2011

OSPF P2MUL NON BROADCAST + LOOPBACK + PATH SELECTION

Today I finished off looking at ospf network types with point to multipoint non broadcast and loopback.
OSPF Network type Point-to-Multipoint Non Broadcast
-----------------------------------------------------
to enable use the command
ip ospf network point-to-multipoint non-broadcast
you manually define address with the neighbor command
This was brought in mainly to support a situation where you have multiple pvcs which are different speeds
we can use the neighbor command in the config to specify cost so cost can be given on per neighbor basis
NO DR/BDR election
it does the same next hop processing as point to multi

router ospf
neighbor 'ip' cost
neighbor 'ip' cost

OSPF network type loopback
---------------------------
ospf has a special network type for loopback (Software based loopbacks) and looped back interfaces (hardware based interfaces)
OSPF will always advertises these as /32 irregardless if the network specfied is not /32
we can change this behavious by using the command ip ospf network point-to-point if this is used it will advertise the correct mask


OSPF PATH SELECTION
--------------------
Once the database are synched between all routers path selection begins
Each router lsa includes a cost value
Best path to a link is lowest end to end cost
Cisco implementation uses bandwidth for deciding cost rfc is arbitiary on defention on how the cost should be caluclated so depends on vendor
- default cisco cost = 100 mbs/link bw

the 100 mbs is the referenced bandwith the cost for 100 mbs link is 1 the cost for 1000mb(1 gb) link is also 1  so we can see a potential issue if you
have higher bandwidth links in your organisation you would want to change the reference value to higher number using the
auto-cost reference bandwidth command under router ospf

When deceding the best path the ospf spf algorithm will look at firstly as normal the longest prefix match if there is multiple prefix matches
then the next thing it looks at is how the ospf router was learnt so in order of preference it is
Intra Area Routes  (o)
Inter Area Routes (oia)
External Type 1 (E1)
External Type 2 (E2)
NSSA Type 1 (N1)
NSSA Type 2 (N2)
then it will look at metric n distance etc

The way ospf works is that for all intra Area so internal ospf routes it will caluclate the metric using the spf algorith and taken into account all the link
states to get to that network in the area
For Inter area routes ospf will calculate the metric to the ABR the ABR will also advertise via type 3 lsa including the abr metric t links external to the
area. So the ospf internal router will add these so it cost to the ABR and ABR advertised cost to the network this will give it the ospf metric for routes
external to the area
if you do
sh ip ospf database summary "ip address" you will see the advertised distance that the abr is sending so the abr metric to the link
When a network changes externally to an area maybe on the backup route to the link the router internally in the area will recieve a update from the ABR
saying it adverised distance has changed as the distance to the ABR has not changed the router only has to do Paritial route calculation. This is much
lighter than the spf algorithm running on the routers which would happen there was internal area change. This is one of the reason it is best pratice to
split ospf into multiple areas.

Modifying Path Selection
--------------------------
OSPF uses bandwidth based cost
so we have few options for changing or influencing path selection
we could edit
on the interface the bandwidth thus affecting the cost ( this is not ideal as other things use bandwidth info which could have knock on affect for example
qos uses bandwidth on the interface
We could use the command
ip ospf cost referenced bandwidth - this would be more ideal just changing the bandwidth in relation to ospf
we could also change reference bandwidth to higher lower cost we do this with the autocost referecne bandwidth command
we could use the command neighbor 'ip ' cost
LAB
----
I will setup point to mulipoint non broadcast with various different speed links
I will also look at path selection dividing the topology into multiple areas.

First lab is the point to multipoint we will do with
r2 is the hub connecting to r1 and  r3
R1 and R3 do not have direct layer 2 connectivity to each other
R1 is higher bandwidth link than r2
 


At the moment all ospf is configured but r1,r2 and r3 are point to multipoint and r1 & r2 have p2p connection to s1
we will take a look at the routing table on r2 as it has 2 paths to s1 loopback 15.15.15.15 via r1  and via r2
r2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 192.168.1.1, 00:00:15, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 192.168.1.3, 00:00:15, Serial0/0
     22.0.0.0/24 is subnetted, 1 subnets
C       22.22.22.0 is directly connected, Loopback0
     12.0.0.0/24 is subnetted, 1 subnets
O       12.12.12.0 [110/65] via 192.168.1.1, 00:00:16, Serial0/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/64] via 192.168.1.1, 00:00:17, Serial0/0
C       192.168.1.0/24 is directly connected, Serial0/0
O       192.168.1.3/32 [110/64] via 192.168.1.3, 00:00:17, Serial0/0
     13.0.0.0/24 is subnetted, 1 subnets
O       13.13.13.0 [110/65] via 192.168.1.3, 00:00:18, Serial0/0
     15.0.0.0/32 is subnetted, 1 subnets
O       15.15.15.15 [110/66] via 192.168.1.3, 00:00:18, Serial0/0
                    [110/66] via 192.168.1.1, 00:00:18, Serial0/0
r2#
As there both equal cost derived from the interface bandwidth of s0/0 which they are connected to it will just divide the bandwidth equally
CEF switching will decide on load balancing suppose the dlci connecting to r1 is 1mb and the dlci connecting to r3 is 512 kb. realistically there is a chance
that r3 dlci could be selected continioulsy i.e default load balancing source + destination mac
We may want to influence this decision this is what ospf point-to-multipoint non broadcast was designed for 
lets start the config on r2

r2
---
r2(config)#int s0/0
r2(config-if)#ip ospf network point-to-multipoint non-broad
ok so network type is changed under the ospf process i need to specify neighbors we will first specify with default cost than we will do unequal costs


r2(config)#router ospf 1
r2(config-router)#neighbor 192.168.1.3
r2(config-router)#neighbor 192.168.1.1
r2(config-router)#exit

r2(config)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 192.168.1.1, 00:00:04, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 192.168.1.3, 00:00:04, Serial0/0
     22.0.0.0/24 is subnetted, 1 subnets
C       22.22.22.0 is directly connected, Loopback0
     12.0.0.0/24 is subnetted, 1 subnets
O       12.12.12.0 [110/65] via 192.168.1.1, 00:00:04, Serial0/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/64] via 192.168.1.1, 00:00:05, Serial0/0
C       192.168.1.0/24 is directly connected, Serial0/0
O       192.168.1.3/32 [110/64] via 192.168.1.3, 00:00:05, Serial0/0
     13.0.0.0/24 is subnetted, 1 subnets
O       13.13.13.0 [110/65] via 192.168.1.3, 00:00:06, Serial0/0
     15.0.0.0/32 is subnetted, 1 subnets
O       15.15.15.15 [110/66] via 192.168.1.3, 00:00:06, Serial0/0
                    [110/66] via 192.168.1.1, 00:00:06, Serial0/0
r2#sh ip ospf database router 22.22.22.22
            OSPF Router with ID (22.22.22.22) (Process ID 1)
                Router Link States (Area 0)
  LS age: 67
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 22.22.22.22
  Advertising Router: 22.22.22.22
  LS Seq Number: 80000009
  Checksum: 0xA07E
  Length: 72
  Number of Links: 4
    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 3.3.3.3
     (Link Data) Router Interface address: 192.168.1.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 64
    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 1.1.1.1
     (Link Data) Router Interface address: 192.168.1.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 64
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 192.168.1.2
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 0
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 22.22.22.22
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

r2#

ok we see both routes in the routing table in the sh ip ospf database both have cost of 64
ok so in our scenerio we  want r1 to be the priority as it is faster dlci than r3 so lets manipulate the costs
r2(config)#router ospf 1
r2(config-router)#neighbor 192.168.1.3 cost 100
r2(config-router)#neighbor 192.168.1.1 cost 12
r2(config-router)#exit

r2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/2] via 192.168.1.1, 00:01:18, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/4] via 192.168.1.1, 00:01:18, Serial0/0
     22.0.0.0/24 is subnetted, 1 subnets
C       22.22.22.0 is directly connected, Loopback0
     12.0.0.0/24 is subnetted, 1 subnets
O       12.12.12.0 [110/2] via 192.168.1.1, 00:01:18, Serial0/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/1] via 192.168.1.1, 00:01:19, Serial0/0
C       192.168.1.0/24 is directly connected, Serial0/0
O       192.168.1.3/32 [110/3] via 192.168.1.1, 00:01:19, Serial0/0
     13.0.0.0/24 is subnetted, 1 subnets
O       13.13.13.0 [110/3] via 192.168.1.1, 00:01:21, Serial0/0
     15.0.0.0/32 is subnetted, 1 subnets
O       15.15.15.15 [110/3] via 192.168.1.1, 00:01:21, Serial0/0
we are only seeing the route via r1

r2#sh ip ospf database router 22.22.22.22
            OSPF Router with ID (22.22.22.22) (Process ID 1)
                Router Link States (Area 0)
  LS age: 52
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 22.22.22.22
  Advertising Router: 22.22.22.22
  LS Seq Number: 8000000B
  Checksum: 0x924
  Length: 72
  Number of Links: 4
    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 3.3.3.3
     (Link Data) Router Interface address: 192.168.1.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 100
    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 1.1.1.1
     (Link Data) Router Interface address: 192.168.1.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 12
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 192.168.1.2
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 0
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 22.22.22.22
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

r2#

we can see why as the metrics in the ospf database have changed.

so this is basically the function of point to multipoint non broadcast networks

Ok for the loopback network i specfied the loopback on sw1 to be 15.15.15.15/24

if we look at the routing table above it is coming in as /32

switch 1
----------
switch1#sh ip int lo0
Loopback0 is up, line protocol is up
  Internet address is 15.15.15.15/24

this is default loopback network type in ospf behaviour if we want to change it we can change the ospf network type to point to point

switch1(config)#int lo0
switch1(config-if)#ip ospf network point-to-point
switch1(config-if)#

Now r2
------
r2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/13] via 192.168.1.1, 00:00:22, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/15] via 192.168.1.1, 00:00:22, Serial0/0
     22.0.0.0/24 is subnetted, 1 subnets
C       22.22.22.0 is directly connected, Loopback0
     12.0.0.0/24 is subnetted, 1 subnets
O       12.12.12.0 [110/13] via 192.168.1.1, 00:00:22, Serial0/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/12] via 192.168.1.1, 00:00:23, Serial0/0
C       192.168.1.0/24 is directly connected, Serial0/0
O       192.168.1.3/32 [110/14] via 192.168.1.1, 00:00:23, Serial0/0
     13.0.0.0/24 is subnetted, 1 subnets
O       13.13.13.0 [110/14] via 192.168.1.1, 00:00:24, Serial0/0
     15.0.0.0/24 is subnetted, 1 subnets
O       15.15.15.0 [110/14] via 192.168.1.1, 00:00:24, Serial0/0
r2#

the 15 network is now /24

ok for the next lab we need to widen it out a bit including ospf areas to view interarea etc




I have configured as per diagram
we will take a look r3 routing table
r3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/794] via 192.168.1.2, 00:00:13, Serial1/0
     2.0.0.0/32 is subnetted, 1 subnets
O IA    2.2.2.2 [110/783] via 192.168.1.2, 00:00:13, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/784] via 192.168.1.2, 00:00:13, Serial1/0
     5.0.0.0/32 is subnetted, 1 subnets
O IA    5.5.5.5 [110/848] via 192.168.1.2, 00:00:13, Serial1/0
     6.0.0.0/32 is subnetted, 1 subnets
O IA    6.6.6.6 [110/784] via 192.168.1.2, 00:00:14, Serial1/0
     172.25.0.0/24 is subnetted, 1 subnets
O IA    172.25.13.0 [110/847] via 192.168.1.2, 00:00:16, Serial1/0
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/782] via 192.168.1.2, 00:00:16, Serial1/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O IA    10.10.10.10/32 [110/783] via 192.168.1.2, 00:00:16, Serial1/0
O IA    10.229.254.0/24 [110/783] via 192.168.1.2, 00:00:16, Serial1/0
O       10.164.49.0/24 [110/782] via 192.168.1.2, 00:00:16, Serial1/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/793] via 192.168.1.2, 00:00:16, Serial1/0
C       192.168.1.0/24 is directly connected, Serial1/0
O       192.168.1.2/32 [110/781] via 192.168.1.2, 00:00:16, Serial1/0

we now see a bunch of ia routes for example 6.6.6.6 network which is in area 0

r3#sh ip ospf database
            OSPF Router with ID (3.3.3.3) (Process ID 1)
                Router Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         278         0x80000005 0x008B09 3
3.3.3.3         3.3.3.3         214         0x80000003 0x00DDCC 3
10.10.10.10     10.10.10.10     391         0x80000003 0x00C3F1 2
22.22.22.22     22.22.22.22     216         0x80000007 0x00F71B 6
                Summary Net Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum
2.2.2.2         10.10.10.10     401         0x80000001 0x000A02
4.4.4.4         10.10.10.10     401         0x80000001 0x00B74B
5.5.5.5         10.10.10.10     401         0x80000001 0x000CB2
6.6.6.6         10.10.10.10     402         0x80000001 0x005B9F
10.10.10.10     10.10.10.10     402         0x80000001 0x009853
10.229.254.0    10.10.10.10     401         0x80000001 0x0028FC
172.25.13.0     10.10.10.10     401         0x80000001 0x006799
r3#

we now are getting summary links state all originating from 10.10.10.10 which has become s2 route id. SW2 is the abr for our area
if we look 6.6.6.6 as an example
r3#sh ip ospf database summary 6.6.6.6
            OSPF Router with ID (3.3.3.3) (Process ID 1)
                Summary Net Link States (Area 1)
  Routing Bit Set on this LSA
  LS age: 955
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 6.6.6.6 (summary Network Number)
  Advertising Router: 10.10.10.10
  LS Seq Number: 80000001
  Checksum: 0x5B9F
  Length: 28
  Network Mask: /32
        TOS: 0  Metric: 2
r3#
we can see the metric is 2 this metric refers to the abr metric to 6.6.6.6 not our so the total metric would be our metric to 10.10.10.10 + this metric of 2


We will do a debug of spf and take down the 6.6.6.6 network and see the affect it has on r3

on r3
-----
*Mar  1 03:21:31.212: OSPF: Detect change in LSA type 3, LSID 6.6.6.6, from 10.10.10.10 area 1
*Mar  1 03:21:31.212: OSPF: Schedule partial SPF - type 3 id 6.6.6.6 adv rtr 10.10.10.10
*Mar  1 03:21:31.212: OSPF: Service partial SPF 1/0/0
*Mar  1 03:21:31.212: OSPF process partial spfQ entry
*Mar  1 03:21:31.212: OSPF process partial spfQ LSA id 6.6.6.6: mask 255.255.255.255, type 3 adv_rtr 10.10.10.10, age 3600, seq 0x80000002 (Area 1)
*Mar  1 03:21:31.216: OSPF process summary partial ABR 0x0 txit 0x0 LSA 6.6.6.6: mask 255.255.255.255, t3 adv 10.10.10.10, age 3600, seq 0x80000002 (Area 1)
so it does partial recalculation only for an interarea network
lets take a look if we take down 1.1.1.1 r1 loopback which is in the same area
Mar  1 03:23:29.094: OSPF: Detect change in LSA type 1, LSID 1.1.1.1, from 1.1.1.1 area 1
*Mar  1 03:23:29.094: OSPF: Schedule SPF in area 1
      Change in LS ID 1.1.1.1, LSA type R, , spf-type Full
*Mar  1 03:23:34.098: OSPF: running SPF for area 1, SPF-type Full
*Mar  1 03:23:34.098: OSPF: Initializing to run spf
*Mar  1 03:23:34.098:  OSPF - spf_intra() - rebuilding the tree
*Mar  1 03:23:34.098:  It is a router LSA 3.3.3.3. Link Count 3
*Mar  1 03:23:34.098:   Processing link 0, id 22.22.22.22, link data 192.168.1.3, type 1
*Mar  1 03:23:34.098:    Add better path to LSA ID 22.22.22.22, gateway 192.168.1.2, dist 781
*Mar  1 03:23:34.098: OSPF: putting LSA on the clist LSID 22.22.22.22, Type 1, Adv Rtr. 22.22.22.22
*Mar  1 03:23:34.102:    Add path: next-hop 192.168.1.2, interface Serial1/0
*Mar  1 03:23:34.102:   Processing link 1, id 192.168.1.3, link data 255.255.255.255, type 3
*Mar  1 03:23:34.102:    Add better path to LSA ID 192.168.1.3, gateway 192.168.1.3, dist 0
*Mar  1 03:23:34.102:    Add path: next-hop 192.168.1.3, interface Serial1/0
*Mar  1 03:23:34.102:   Processing link 2, id 3.3.3.3, link data 255.255.255.255, type 3
*Mar  1 03:23:34.106:    Add better path to LSA ID 3.3.3.3, gateway 3.3.3.3, dist 1
*Mar  1 03:23:34.106:    Add path: next-hop 3.3.3.3, interface Loopback0
*Mar  1 03:23:34.106: OSPF: downheap LSA on the clist LSID 22.22.22.22, Type 1, Adv Rtr. 22.22.22.22,
                              from index 1 to index 1
*Mar  1 03:23:34.106:  It is a router LSA 22.22.22.22. Link Count 6
*Mar  1 03:23:34.106:   Processing link 0, id 1.1.1.1, link data 192.168.1.2, type 1
*Mar  1 03:23:34.106:    Add better path to LSA ID 1.1.1.1, gateway 192.168.1.1, dist 793
*Mar  1 03:23:34.110: OSPF: putting LSA on the clist LSID 1.1.1.1, Type 1, Adv Rtr. 1.1.1.1
*Mar  1 03:23:34.110:    Add path: next-hop 192.168.1.2, interface Serial1/0
*Mar  1 03:23:34.110:   Processing link 1, id 3.3.3.3, link data 192.168.1.2, type 1
*Mar  1 03:23:34.110:   Ignore newdist 881 olddist 0
*Mar  1 03:23:34.110:   Processing link 2, id 192.168.1.2, link data 255.255.255.255, type 3
*Mar  1 03:23:34.114:    Add better path to LSA ID 192.168.1.2, gateway 192.168.1.2, dist 781
*Mar  1 03:23:34.114:    Add path: next-hop 192.168.1.2, interface Serial1/0
*Mar  1 03:23:34.114:   Processing link 3, id 22.22.22.22, link data 255.255.255.255, type 3
*Mar  1 03:23:34.114:    Add better path to LSA ID 22.22.22.22, gateway 22.22.22.22, dist 782
*Mar  1 03:23:34.118:    Add path: next-hop 192.168.1.2, interface Serial1/0
*Mar  1 03:23:34.118:   Processing link 4, id 10.10.10.10, link data 10.164.49.22, type 1
*Mar  1 03:23:34.118:    Add better path to LSA ID 10.10.10.10, gateway 10.164.49.2, dist 782
*Mar  1 03:23:34.118: OSPF: putting LSA on the clist LSID 10.10.10.10, Type 1, Adv Rtr. 10.10.10.10
*Mar  1 03:23:34.122: OSPF: upheap LSA on the clist LSID 10.10.10.10, Type 1, Adv Rtr. 10.10.10.10,
                              from index 2 to index 1
*Mar  1 03:23:34.122:    Add path: next-hop 192.168.1.2, interface Serial1/0
*Mar  1 03:23:34.122:   Processing link 5, id 10.164.49.0, link data 255.255.255.0, type 3
*Mar  1 03:23:34.126:    Add better path to LSA ID 10.164.49.255, gateway 10.164.49.0, dist 782
*Mar  1 03:23:34.126:    Add path: next-hop 192.168.1.2, interface Serial1/0
*Mar  1 03:23:34.126: OSPF: downheap LSA on the clist LSID 1.1.1.1, Type 1, Adv Rtr. 1.1.1.1,
                              from index 1 to index 1
*Mar  1 03:23:34.126: OSPF: delete lsa id 10.10.10.10, type 1, adv rtr 10.10.10.10 from delete list
*Mar  1 03:23:34.130: OSPF: Add ABR Router Route to 10.10.10.10 via 192.168.1.2. Metric: 782. Area 1
*Mar  1 03:23:34.130: OSPF: insert route list LS ID 10.10.10.10, type 1, adv rtr 10.10.10.10
*Mar  1 03:23:34.130:  It is a router LSA 10.10.10.10. Link Count 2
*Mar  1 03:23:34.130:   Processing link 0, id 22.22.22.22, link data 10.164.49.2, type 1
*Mar  1 03:23:34.134:   Ignore newdist 783 olddist 781
*Mar  1 03:23:34.134:   Processing link 1, id 10.164.49.0, link data 255.255.255.0, type 3
*Mar  1 03:23:34.134:    Add better path to LSA ID 10.164.49.255, gateway 10.164.49.0, dist 783
*Mar  1 03:23:34.134:    Add path: next-hop 192.168.1.2, interface Serial1/0
*Mar  1 03:23:34.138: OSPF: downheap LSA on the clist LSID 1.1.1.1, Type 1, Adv Rtr. 1.1.1.1,
                              from index 1 to index 1
*Mar  1 03:23:34.138:  It is a router LSA 1.1.1.1. Link Count 2
*Mar  1 03:23:34.138:   Processing link 0, id 22.22.22.22, link data 192.168.1.1, type 1
*Mar  1 03:23:34.138:   Ignore newdist 857 olddist 781
*Mar  1 03:23:34.138:   Processing link 1, id 192.168.1.1, link data 255.255.255.255, type 3
*Mar  1 03:23:34.142:    Add better path to LSA ID 192.168.1.1, gateway 192.168.1.1, dist 793
*Mar  1 03:23:34.142:    Add path: next-hop 192.168.1.2, interface Serial1/0
this is only partial extract of the debug we can see we have to do a full spf recalculation this would happen all routers in the area

ok we will take a quick look at referenced bandwidth
on s1/0 i have set the bandwidth to 100 mb
int s1/0
r3(config-if)#bandwidth 100000
r3#sh ip ospf int
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 1
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 1
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:10
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 3
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 22.22.22.22
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
  Internet Address 3.3.3.3/32, Area 1
  Process ID 1, Router ID 3.3.3.3, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
r3#

ospf cost is 1
i will now set the bandwidth to 10 gb
r3(config)#int s1/0
r3(config-if)#bandwidth 10000000
r3(config-if)#
r3#sh ip ospf int
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 1
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 1
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:27
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 3
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 22.22.22.22
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
  Internet Address 3.3.3.3/32, Area 1
  Process ID 1, Router ID 3.3.3.3, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub
the cost is the exact same so by default if we had a 10 g link and 100 mbs link we would look at them the same not definetly given preference to 10 g link
r3(config-router)#router ospf 1
r3(config-router)#auto-cost reference-bandwidth 1000000
% OSPF: Reference bandwidth is changed.
        Please ensure reference bandwidth is consistent across all routers.
r3(config-router)#

r3(config-if)#int s1/0
r3(config-if)#bandwidth 10000000  >>> 10 gb
r3(config-if)#exit
r3(config)#exit
r3#sh ip osp
*Mar  1 03:37:25.861: %SYS-5-CONFIG_I: Configured from console by consolef int
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 1
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 100
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 3
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 22.22.22.22
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
  Internet Address 3.3.3.3/32, Area 1
  Process ID 1, Router ID 3.3.3.3, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host


the cost for this is now 100
while if i do the 100 mbs again
r3#config t
Enter configuration commands, one per line.  End with CNTL/Z.
r3(config)#int s1/0
r3(config-if)#bandwidth 1000000
r3(config-if)#exit
r3(config)#exit

r3#sh ip ospf int
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 1
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 1000
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:11
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 3
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 22.22.22.22
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
  Internet Address 3.3.3.3/32, Area 1
  Process ID 1, Router ID 3.3.3.3, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
r3#

cost is 1000 so the 10 g is the most preference as of lower cost so now ospf can deal with higher bandwidth links

Thursday, December 29, 2011

OSPF NETWORK TYPES

Ok today i looked further into OSPF network types
OSPF has a media dependency it behaviour changes depending on the media it is connected to
e.g ethernet,frame relay so on
different media will default to different network types
these network types will control
- how updates are sent
- who forms adjacencies
-how the next hop is calculated

OSPF NETWORK TYPES
-------------------
broadcast
nonbroadcast
point-to-point
point-to-multipoint
point-to-multipoint non broadcast
loopback

Today I looked at broadcast,non broadcast,point-to-point and point to multipoint

OSPF NETWORK TYPE BROADCAST
-----------------------------
you turn it on with
ip ospf network broadcast  on the interface
it is the default on multiaccess broadcast medias
 - ethernet,fddi,token ring
sends hello + updates as multicast (protocol 88)
  - 224.0.0.5 ( ALL OSPF ROUTERS)
  - 224.0.0.6 (ALL DR/BDR ROUTERS)
Perform an election to decide on DR and BDR for segment
DR/BDR Overview
-----------------
Designated ROuter (DR)
  - used on broadcast links to minimise adjacencies and minimize lsa replication
Backup Designated Router (BDR)
  - used as redudancy for DR
DROTHERS
   - all other routers on link
   - form full adjacency with DR + BDR
   - stop at the 2 way state for all other DROTHER routers as full adjacency is not required
The process is that when DROTHER wants to send an update it will multicast the update to
the address 224.0.0.6 only DR + BDR listen for this multicast when recieved the BDR will
effectively do nothing with it the DR will multicast the update out to all routers using the
multicast address 224.0.0.5
ELECTION OF DR/BDR
---------------------
There is 2 elements to the DR/BDR election
first is priority
you can assign a priority value of 0-255
higher is better
0 is never use
second element is router id
which is the highest loopback/interface ip
can be statically configured
higher is better

when dr/bdr is selected it can not be preempted

There can be issue with the DR in partial mesh scenerios ospf unicasts + multicast are link
local they should not be routed between interfaces and have ttl of 1
given that in a partial mesh where spoke routers do not have layer 2 connectivity to each
other if using broadcast non broadcast you need to control the  election to ensure that the
hub is selected as DR as if a spoke is selected it will cause issues. You can do this by
rigging the election setting the spoke router priority to 0

OSPF NON BROADCAST
--------------------
ip ospf network non-broadcast - interface command to turn on
default on multipoint nbma medias
 - frame-relay & atm
sends hellos as unicast  ( main difference between broadcast + non broadcast)
- you need to manually define neighbors with the neighbor command under router ospf process
- performs and DR/BDR election
-DR needs to have full layer 2 reachability to all routers on segment
To rig election on spokes
ip ospf priority 0
on the hub + bdr
do the neighbor command

Next HOP
----------
OSPF in broadcast/nonbroadcast network the dr will leave the next hop and not change it. This is
preference in most configs you do not have to route to the dr then onto the next hop as typically
you would have layer 2 connectivity to the original next hop.
But this not always the case in a partial mesh network this can cause issues as you do not
have layer 2 connectivity you could do a few solutions like doing static mappings for each next hop
ip pointing and the dlci you connect out of or changin the frame-relay connectivity to p2p
ANother solution would be to use OSPF Point-to MULTIPOINT

OSPF POINT TO MULTIPOINT
-------------------------
enable with ip ospf network point-to-multipoint on interface
treats the networks as acollection of point-to-point links
sends hello as multicast to 224.0.0.5
no bdr and dr election
special next hop process it will change the next hop to the dr
ANother network type is
OSPF NETWORK POINT-TO-POINT
---------------------------
ip ospf network point-to-point on interface to enable
default on hdlc/ppp links
sends hello as multicast to 224.0.0.5
no bdr/dr election
supports only 2 neighbor on the link
no type lsa 2 network generated as no dr/bdr

So in the break down
DR/BDR ELECTION is requires in BROADCAST NETWORK and NON BROADCAST NETWORk + these two can
be mixed network types on a segment it is possible to have 1 interface configured as BROADCAST
and another configured as non broacast and it would work ok. They will not be compatiable with
the other network types

NO DR/BDR ELECTIOn required on point to point point to multipoint and point to multipoint non broadcast
these can be mixed togther they are compatiable

if you try and mix for example a p2p with broadcast they will form a adjacency so it can be hard to
detect and will appear to be working in sh ip ospf database command but there will be a faulure in
the spf run as the database will not be consitent and agree on networks so the route will never go
into the routing table
LAB
-----
For the lab we will use the previous config and bring in frame relay portion with r2 connecting to r1 and r3 over frame relay we will do the different
network types

ok so i have booted up the equitment already configured on the broadcast segment vlan 100 that sw4 is connecting
switch2#sh ip ospf int
Port-channel8 is up, line protocol is up (connected)
  Internet Address 10.229.254.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 4.4.4.4, Interface address 10.229.254.4
  Backup Designated router (ID) 2.2.2.2, Interface address 10.229.254.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 4.4.4.4  (Designated Router)
    Adjacent with neighbor 6.6.6.6
  Suppress hello for 0 neighbor(s)
FastEthernet0/2 is up, line protocol is up (connected)
  Internet Address 10.164.49.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 1
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 22.22.22.22
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
  Internet Address 2.2.2.2/32, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
switch2#
router 4 has become the dr and router 6 has become the bdr just showing that it is really down to order of operation. Typically it should be highest router
id but if a router boots up significtanly faster than other routers it can become the dr before the higher router id comes online. In this case the highest
router id which with leaving default priorities should have become the dr has become drother neither the dr or the bdr as obviously sw2 and r4 where faster
booting up once there is dr elected it will not be preempted

Now we can just check out something else on this what happens if router 4 is put into the incorrect vlan
I will configure on sw4 fa0/4 connecting to r4 the port to be in vlan 101 segragating from sw2 and r6 who are in vlan 100


i will put a debug on r4 and sw2
debug ip ospf event
debug ip ospf adj

sw2
----
00:50:37: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4 on Port-channel8 from FULL to DOWN
DOWN, Neighbor Down: Dead timer expired
00:50:37: OSPF: Neighbor change Event on interface Port-channel8
00:50:37: OSPF: DR/BDR election on Port-channel8
00:50:37: OSPF: Elect BDR 2.2.2.2
00:50:37: OSPF: Elect DR 2.2.2.2
00:50:37: OSPF: Elect BDR 6.6.6.6
00:50:37: OSPF: Elect DR 2.2.2.2
00:50:37:        DR: 2.2.2.2 (Id)   BDR: 6.6.6.6 (Id)
00:50:37: OSPF: Remember old DR 4.4.4.4 (id)
00:50:38: OSPF: Rcv LS UPD from 6.6.6.6 on Port-channel8 length 76 LSA count 1
00:50:38: OSPF: Build router LSA for area 0, router ID 2.2.2.2, seq 0x8000000A
00:50:38: OSPF: Build network LSA for Port-channel8, router ID 2.2.2.2
00:50:38: OSPF: Build network LSA for Port-channel8, router ID 2.2.2.2
00:50:40: OSPF: Send hello to 224.0.0.5 area 0 on Port-channel8 from 10.229.254.2
00:50:42: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet0/2 from 10.164.49.2
00:50:42: OSPF: Rcv hello from 22.22.22.22 area 0 from FastEthernet0/2 10.164.49.22
00:50:42: OSPF: End of hello processing
00:50:45: OSPF: Rcv hello from 6.6.6.6 area 0 from Port-channel8 10.229.254.6
00:50:45: OSPF: Neighbor change Event on interface Port-channel8
00:50:45: OSPF: DR/BDR election on Port-channel8
00:50:45: OSPF: Elect BDR 6.6.6.6
00:50:45: OSPF: Elect DR 2.2.2.2
00:50:45:        DR: 2.2.2.2 (Id)   BDR: 6.6.6.6 (Id)
00:50:45: OSPF: Neighbor change Event on interface Port-channel8
00:50:45: OSPF: DR/BDR election on Port-channel8

we can see there is an election after 4.4.4.4 r4 goes down automatically the bdr 2.2.2.2 becomes DR and then for BDR it is down to the highest route id of
the DR other which is r6  6.6.6.6 so eventhough 6.6.6.6 is higher than router id 2.2.2.2 because 2.2.2.2 is already bdr it is straight away promoted the
election is not for dr but for who will be bdr

r4
---
*Dec 29 19:36:45.563: %OSPF-5-ADJCHG: Process 1, Nbr 6.6.6.6 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Dead timer expired
*Dec 29 19:36:45.563: OSPF: Neighbor change Event on interface FastEthernet0/1
*Dec 29 19:36:45.563: OSPF: DR/BDR election on FastEthernet0/1
*Dec 29 19:36:45.563: OSPF: Elect BDR 0.0.0.0
*Dec 29 19:36:45.563: OSPF: Elect DR 4.4.4.4
*Dec 29 19:36:45.563:        DR: 4.4.4.4 (Id)   BDR: none
*Dec 29 19:36:46.063: OSPF: Build router LSA for area 0, router ID 4.4.4.4, seq 0x80000007, process 1
*Dec 29 19:36:46.063: OSPF: No full nbrs to build Net Lsa for interface FastEthernet0/1
*Dec 29 19:36:46.171: OSPF: No full nbrs to build Net Lsa for interface FastEthernet0/1
*Dec 29 19:36:46.171: OSPF: Build network LSA for FastEthernet0/1, router ID 4.4.4.4

we can see r4 now in different broadcast domain as of the vlan change does a new election as there is no other routers on the segment it elects itseld dr and
obvioulsy there is no bdr


We will put fa0/4 on sw2 back to vlan 100

r4
---
state 2WAY
*Dec 29 19:46:17.863: OSPF: Neighbor change Event on interface FastEthernet0/1
*Dec 29 19:46:17.863: OSPF: DR/BDR election on FastEthernet0/1
*Dec 29 19:46:17.863: OSPF: Elect BDR 6.6.6.6
*Dec 29 19:46:17.863: OSPF: Elect DR 4.4.4.4
*Dec 29 19:46:17.863:        DR: 4.4.4.4 (Id)   BDR: 6.6.6.6 (Id)
*Dec 29 19:46:17.863: OSPF: Send DBD to 6.6.6.6 on FastEthernet0/1 seq 0x1A37 opt 0x52 flag 0x7 len 32
*Dec 29 19:46:17.863: OSPF: NBR Negotiation Done. We are the SLAVE
*Dec 29 19:46:17.863: OSPF: Send DBD to 6.6.6.6 on FastEthernet0/1 seq 0x14E8 opt 0x52 flag 0x2 len 132
*Dec 29 19:46:17.867: OSPF: Rcv DBD from 6.6.6.6 on FastEthernet0/1 seq 0x14E9 opt 0x52 flag 0x3 len 172  mtu 1500 state EXCHANGE

it has prempted the current dr of 2.2.2.2 this the only situation where preemption could take place as it acted as dr as it was dr on the other segment and
has superior router id it become dr

NONBROADCAST
------------
ok we will move onto the frame relay section of the diagram r2,r1 and r3 it is a partial mesh r2 has connectivity to both r1 & r3 but r1 and r3 does not have
direct layer 2 connectivity to each other. So i will configue the routers in nonbroadcast they will be in the 192.168.1.0/24

ok so i have configured the frame-relay and ip
r2 is 192.168.1.2   r1 192.168.1.1 r3 192.168.1.3

ok on r2
---------
r2(config)#router ospf 1
r2(config-router)#network 192.168.1.2 0.0.0.0 area 0

r2(config)#do sh ip ospf int s0/0
Serial0/0 is up, line protocol is up
  Internet Address 192.168.1.2/24, Area 0
  Process ID 1, Router ID 22.22.22.22, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State WAITING, Priority 1
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:10
    Wait time before Designated router selection 00:01:40
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
ok first i will check the interface set to non broadcast



ok same on r3
--------------
r3(config)#router ospf 1
r3(config-router)#network 192.168.1.0 0.0.0.255 area 0
r3(config-router)#exit
r3(config)#exit
r3#
*Mar  1 01:39:24.112: %SYS-5-CONFIG_I: Configured from console by console
r3#sh ip ospf int
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 0
  Process ID 1, Router ID 192.168.1.3, Network Type NON_BROADCAST, Cost: 781
  Transmit Delay is 1 sec, State WAITING, Priority 1
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:02
    Wait time before Designated router selection 00:01:32
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
r3#

adjacency is not forming with r2

*Mar  1 01:41:02.153: OSPF: end of Wait on interface Serial1/0
*Mar  1 01:41:02.153: OSPF: DR/BDR election on Serial1/0
*Mar  1 01:41:02.153: OSPF: Elect BDR 192.168.1.3
*Mar  1 01:41:02.153: OSPF: Elect DR 192.168.1.3
*Mar  1 01:41:02.153: OSPF: Elect BDR 0.0.0.0
*Mar  1 01:41:02.153: OSPF: Elect DR 192.168.1.3
*Mar  1 01:41:02.153:        DR: 192.168.1.3 (Id)   BDR: none
*Mar  1 01:41:02.654: OSPF: No full nbrs to build Net Lsa for interface Serial
r3 has elected it self as dr and is picking no other routers on the segmenet this is as it needs to be told what address to unicast to instead of multicast

r3(config)#router ospf 1
r3(config-router)#neighbor 192.168.1.2
r3(config-router)#
*Mar  1 01:43:23.857: OSPF: Starting 0.0.0.0 address 192.168.1.2 on Serial1/0
r3# sh ip ospf neigh
Neighbor ID     Pri   State           Dead Time   Address         Interface
22.22.22.22       1   FULL/DROTHER    00:01:48    192.168.1.2     Serial1/0
r3#


i will bring r1 into it

r1
-----

r1#config t
Enter configuration commands, one per line.  End with CNTL/Z.
r1(config)#router ospf 1
r1(config-router)#network 192.168.1.0 0.0.0.255 area 0
r1(config-router)#network 1.1.1.1 0.0.0.0 area 0
r1(config-router)#neighbor 192.168.1.2

Neighbor ID     Pri   State           Dead Time   Address         Interface
22.22.22.22       1   FULL/BDR        00:01:56    192.168.1.2     Serial0/0

r1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Serial0/0
r1#
i am not learning any routes

on r1 i believe that i am the dr

Serial0/0 is up, line protocol is up
  Internet Address 192.168.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 192.168.1.1
  Backup Designated router (ID) 22.22.22.22, Interface address 192.168.1.2
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:09
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 22.22.22.22  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
r1#
I have no layer 2 connectivity to 192.168.1.3 the original DR so i elected myself


on r2
------
r2#sh ip ospf int
Serial0/0 is up, line protocol is up
  Internet Address 192.168.1.2/24, Area 0
  Process ID 1, Router ID 22.22.22.22, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 192.168.1.3, Interface address 192.168.1.3
  Backup Designated router (ID) 22.22.22.22, Interface address 192.168.1.2
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:24
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 1.1.1.1
    Adjacent with neighbor 192.168.1.3  (Designated Router)
  Suppress hello for 0 neighbor(s)

it still believes r3 is the dr

on r2

r2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 10.164.49.2, 00:04:14, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 192.168.1.3, 00:04:14, Serial0/0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/3] via 10.164.49.2, 00:04:14, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/67] via 10.164.49.2, 00:04:14, FastEthernet0/0
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/3] via 10.164.49.2, 00:04:15, FastEthernet0/0
     172.25.0.0/24 is subnetted, 1 subnets
O       172.25.13.0 [110/66] via 10.164.49.2, 00:04:15, FastEthernet0/0
     22.0.0.0/24 is subnetted, 1 subnets
C       22.22.22.0 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.10/32 [110/2] via 10.164.49.2, 00:04:17, FastEthernet0/0
O       10.229.254.0/24 [110/2] via 10.164.49.2, 00:04:17, FastEthernet0/0
C       10.164.49.0/24 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, Serial0/0
r2#
i have no route to r1 loopack

r2#sh ip ospf database router 1.1.1.1
            OSPF Router with ID (22.22.22.22) (Process ID 1)
                Router Link States (Area 0)
  Adv Router is not-reachable
  LS age: 489
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 1.1.1.1
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000003
  Checksum: 0xA35A
  Length: 48
  Number of Links: 2
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 1.1.1.1
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1
    Link connected to: a Transit Network
     (Link ID) Designated Router address: 192.168.1.1
     (Link Data) Router Interface address: 192.168.1.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

r2#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/65/68 ms
r2#

i am recieving r1 advertisment on 1.1.1.1 but there is incosistency in the database so the spf algorithm is not going to run correctly

on r3
-----
r3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/783] via 192.168.1.2, 00:10:25, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/784] via 192.168.1.2, 00:10:25, Serial1/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/848] via 192.168.1.2, 00:10:25, Serial1/0
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/784] via 192.168.1.2, 00:10:25, Serial1/0
     172.25.0.0/24 is subnetted, 1 subnets
O       172.25.13.0 [110/847] via 192.168.1.2, 00:10:26, Serial1/0
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/782] via 192.168.1.2, 00:10:27, Serial1/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.10/32 [110/783] via 192.168.1.2, 00:10:27, Serial1/0
O       10.229.254.0/24 [110/783] via 192.168.1.2, 00:10:27, Serial1/0
O       10.164.49.0/24 [110/782] via 192.168.1.2, 00:10:27, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
r3#

i am recieving all routes apart from 1.1.1.1 effectively r1 has been segragated from the ospf process as it does not agree on dr router etc as it has no
connectivity to the dr to sort this out we need to make sure that the router that has layer 2 connectivity to both becomes the dr


r3
---
r3(config)#router ospf 1
r3(config-router)#no neighbor 192.168.1.2
r3(config-router)#
*Mar  1 02:04:46.925: %OSPF-5-ADJCHG: Process 1, Nbr 22.22.22.22 on Serial1/0 from FULL to DOWN, Neighbor Down: Neighbor deconfigured
r3(config-router)#

r1
---

r1(config)#router ospf 1
r1(config-router)#no neighbor 192.168.1.2
r1(config-router)#
*Mar  1 01:52:33.855: %OSPF-5-ADJCHG: Process 1, Nbr 22.22.22.22 on Serial0/0 from FULL to DOWN, Neighbor Down: Neighbor deconfigured
r1(config-if)#int s0/0
r1(config-if)#ip ospf priority 0   - specifying it is not to become dr/bdr
r1(config-if)#
r3(config)#int s1/0
r3(config-if)#ip ospf priority 0
r3(config-if)#



r2
---
r2(config)#router ospf 1
r2(config-router)#neighbor 192.168.1.2
r2(config-router)#neighbor 192.168.1.1
r2(config-router)#neighbor 192.168.1.3
r
i will do a shut and no shut on my frame-relay int to clear the ospf process

r2#
*Mar  1 04:57:06.095: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial0/0 from LOADING to FULL, Loading Don
r2#sh ip ospf neigh
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/DROTHER    00:01:59    192.168.1.1     Serial0/0
192.168.1.3       0   FULL/DROTHER    00:01:56    192.168.1.3     Serial0/0
2.2.2.2           0   FULL/  -        00:00:36    10.164.49.2     FastEthernet0/0
r2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 192.168.1.1, 00:00:04, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 10.164.49.2, 00:00:04, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 192.168.1.3, 00:00:04, Serial0/0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/3] via 10.164.49.2, 00:00:04, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/67] via 10.164.49.2, 00:00:05, FastEthernet0/0
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/3] via 10.164.49.2, 00:00:05, FastEthernet0/0
     172.25.0.0/24 is subnetted, 1 subnets
O       172.25.13.0 [110/66] via 10.164.49.2, 00:00:06, FastEthernet0/0
     22.0.0.0/24 is subnetted, 1 subnets
C       22.22.22.0 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.10/32 [110/2] via 10.164.49.2, 00:00:06, FastEthernet0/0
O       10.229.254.0/24 [110/2] via 10.164.49.2, 00:00:06, FastEthernet0/0
C       10.164.49.0/24 is directly connected, FastEthernet0/0
C    192.168.1.0/24 is directly connected, Serial0/0
r2#sh ip ospf int
Serial0/0 is up, line protocol is up
  Internet Address 192.168.1.2/24, Area 0
  Process ID 1, Router ID 22.22.22.22, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 22.22.22.22, Interface address 192.168.1.2
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:29
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 1.1.1.1
    Adjacent with neighbor 192.168.1.3
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
  Internet Address 22.22.22.22/24, Area 0
  Process ID 1, Router ID 22.22.22.22, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
FastEthernet0/0 is up, line protocol is up
  Internet Address 10.164.49.22/24, Area 0
  Process ID 1, Router ID 22.22.22.22, Network Type POINT_TO_POINT, Cost: 1
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:09
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)
r2#
now we  the dr has full layer 2 connectivity beween the spokles everything as as expected we are seeing all routes

we will look at the routing table on r3

All looks good on r3- the spoke is dr other and has the full routing table
r3#sh ip ospf int
Loopback0 is up, line protocol is up
  Internet Address 3.3.3.3/32, Area 0
  Process ID 1, Router ID 192.168.1.3, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 0
  Process ID 1, Router ID 192.168.1.3, Network Type NON_BROADCAST, Cost: 781
  Transmit Delay is 1 sec, State DROTHER, Priority 0
  Designated Router (ID) 22.22.22.22, Interface address 192.168.1.2
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:28
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 22.22.22.22  (Designated Router)
  Suppress hello for 0 neighbor(s)
r3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/782] via 192.168.1.1, 00:10:36, Serial1/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/783] via 192.168.1.2, 00:10:36, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/784] via 192.168.1.2, 00:10:36, Serial1/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/848] via 192.168.1.2, 00:10:36, Serial1/0
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/784] via 192.168.1.2, 00:10:37, Serial1/0
     172.25.0.0/24 is subnetted, 1 subnets
O       172.25.13.0 [110/847] via 192.168.1.2, 00:10:38, Serial1/0
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/782] via 192.168.1.2, 00:10:38, Serial1/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.10/32 [110/783] via 192.168.1.2, 00:10:38, Serial1/0
O       10.229.254.0/24 [110/783] via 192.168.1.2, 00:10:38, Serial1/0
O       10.164.49.0/24 [110/782] via 192.168.1.2, 00:10:38, Serial1/0
C    192.168.1.0/24 is directly connected, Serial1/0
r3#
we do have an issue though

r3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r3#

if we look at the route to 1.1.1.1
O       1.1.1.1 [110/782] via 192.168.1.1, 00:10:36, Serial1/0

it has a next hop of 192.168.1.1

we have no layer 2 connectivity to this next hop so it fails

we have a few options of repairing
under the s0/0 int on r3
we could put a map for 192.168.1.1 via dlci 302
we could change the frame-relay interface to point-to-point (not the ospf network type) just the frame relay interface
or we could look at network type designed for hub and spoke partial meshes which is point to multipoint we will look at the broadcast version of point
to multipoint first

to enable point to multipoint we just use ip ospf network point to multipoint command under each router frame relay int

so on
r3
---

r3(config)#int s1/0
r3(config-if)#ip ospf network point-to-multipoint
r3(config-if)#

we do the same on r2 and r1

on r2
r2#sh ip ospf nei
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.3       0   FULL/  -        00:01:58    192.168.1.3     Serial0/0
1.1.1.1           0   FULL/  -        00:01:58    192.168.1.1     Serial0/0
2.2.2.2           0   FULL/  -        00:00:38    10.164.49.2     FastEthernet0/0
r2#
full/- means there no bdr/dr election
r3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/846] via 192.168.1.2, 00:01:48, Serial1/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/783] via 192.168.1.2, 00:01:48, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/784] via 192.168.1.2, 00:01:48, Serial1/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/848] via 192.168.1.2, 00:01:48, Serial1/0
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/784] via 192.168.1.2, 00:01:49, Serial1/0
     172.25.0.0/24 is subnetted, 1 subnets
O       172.25.13.0 [110/847] via 192.168.1.2, 00:01:54, Serial1/0
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/782] via 192.168.1.2, 00:01:54, Serial1/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.10/32 [110/783] via 192.168.1.2, 00:01:54, Serial1/0
O       10.229.254.0/24 [110/783] via 192.168.1.2, 00:01:54, Serial1/0
O       10.164.49.0/24 [110/782] via 192.168.1.2, 00:01:54, Serial1/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/845] via 192.168.1.2, 00:01:54, Serial1/0
C       192.168.1.0/24 is directly connected, Serial1/0
O       192.16
if we look at 1.1.1.1 it next hop is 192.168.1.2 not 1.1

r3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/133/141 ms
r3#

i can ping successifully

ok we will now try to mix interface types we will start with point to point and point to multipoint
so we will change r3 to point to point r2 will remain point-to-multi


r3
---

r3(config)#int s1/0
r3(config-if)#ip ospf network point-to-point
r3(config-if)#
*Mar  1 03:53:49.718: %OSPF-5-ADJCHG: Process 1, Nbr 22.22.22.22 on Serial1/0 from FULL to DOWN, Neighbor Down: Interface down or detached
ok the adjacency is not forming

r3#
*Mar  1 03:57:44.940: OSPF: rcv. v:2 t:1 l:48 rid:22.22.22.22
      aid:0.0.0.0 chk:BE08 aut:0 auk: from Serial1/0
*Mar  1 03:57:44.940: OSPF: Rcv hello from 22.22.22.22 area 0 from Serial1/0 192.168.1.2
*Mar  1 03:57:44.944: OSPF: Mismatched hello parameters from 192.168.1.2
*Mar  1 03:57:44.944: OSPF: Dead R 120 C 40, Hello R 30 C 10

it is not forming because the timers are mismatched
r3#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
  Internet Address 192.168.1.3/24, Area 0
  Process ID 1, Router ID 192.168.1.3, Network Type POINT_TO_POINT, Cost: 781
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:05
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
r3#

r2#sh ip ospf int
Serial0/0 is up, line protocol is up
  Internet Address 192.168.1.2/24, Area 0
  Process ID 1, Router ID 22.22.22.22, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:11
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1
  Suppress hello for 0 neighbor(s)

so r3 timers are hello 10 dead 40  and r2 timers are 30 120

so on r3 we will change the timers to match r2 timers

r3
---
r3(config)#int s1/0
r3(config-if)#ip ospf hello 30
r3(config-if)#ip ospf dead  120
r3(config-if)#

r3#
*Mar  1 04:01:25.629: %SYS-5-CONFIG_I: Configured from console by console
r3#sh ip ospf nei
Neighbor ID     Pri   State           Dead Time   Address         Interface
22.22.22.22       0   FULL/  -        00:01:59    192.168.1.2     Serial1/0
r3#
*Mar  1 04:01:44.973: %OSPF-5-ADJCHG: Process 1, Nbr 22.22.22.22 on Serial1/0 from LOADING to FULL, Loading Done

now we formed adjacency

r3#
*Mar  1 04:01:44.973: %OSPF-5-ADJCHG: Process 1, Nbr 22.22.22.22 on Serial1/0 from LOADING to FULL, Loading Done
r3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/846] via 192.168.1.2, 00:00:11, Serial1/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/783] via 192.168.1.2, 00:00:11, Serial1/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/784] via 192.168.1.2, 00:00:11, Serial1/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/848] via 192.168.1.2, 00:00:11, Serial1/0
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/784] via 192.168.1.2, 00:00:12, Serial1/0
     172.25.0.0/24 is subnetted, 1 subnets
O       172.25.13.0 [110/847] via 192.168.1.2, 00:00:13, Serial1/0
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/782] via 192.168.1.2, 00:00:13, Serial1/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.10/32 [110/783] via 192.168.1.2, 00:00:13, Serial1/0
O       10.229.254.0/24 [110/783] via 192.168.1.2, 00:00:13, Serial1/0
O       10.164.49.0/24 [110/782] via 192.168.1.2, 00:00:13, Serial1/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
O       192.168.1.1/32 [110/845] via 192.168.1.2, 00:00:13, Serial1/0
C       192.168.1.0/24 is directly connected, Serial1/0
O       192.168.1.2/32 [110/781] via 192.168.1.2, 00:00:13, Serial1/0
r3#

we are getting all the routes and can ping 1.1.1.
lets try changing r3 network type to ospf broadbcast and see how it reacts these are not compatiable

r3(config)#int s1/0
r3(config-if)#ip ospf network broad
r3(config-if)#

ok on r3
--------
r3#
*Mar  1 04:05:20.743: %OSPF-5-ADJCHG: Process 1, Nbr 22.22.22.22 on Serial1/0 from LOADING to FULL, Loading Done
r3#sh ip ospf nei
Neighbor ID     Pri   State           Dead Time   Address         Interface
22.22.22.22       1   FULL/DR         00:01:52    192.168.1.2     Serial1/0
r3#

all loooks good for broadcast network we full adjacency

on 
r2
----
r2#sh ip ospf neigh
Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.3       0   FULL/  -        00:01:56    192.168.1.3     Serial0/0

i have full but it is a point to multipoint or point to multipo non broadcast or point to point

r2#sh ip ospf int
Serial0/0 is up, line protocol is up
  Internet Address 192.168.1.2/24, Area 0
  Process ID 1, Router ID 22.22.22.22, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:05
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 192.168.1.3
    Adjacent with neighbor 1.1.1.1
  Suppress hello for 0 neighbor(s)
so the interface is point to multipoint and the adjacency is showing up full
if we look at the ospf database
on r2
r2#sh ip ospf database router 192.168.1.3
            OSPF Router with ID (22.22.22.22) (Process ID 1)
                Router Link States (Area 0)
  Adv Router is not-reachable
  LS age: 274
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 192.168.1.3
  Advertising Router: 192.168.1.3
  LS Seq Number: 80000012
  Checksum: 0x69D7
  Length: 48
  Number of Links: 2
    Link connected to: a Transit Network
     (Link ID) Designated Router address: 192.168.1.2
     (Link Data) Router Interface address: 192.168.1.3
      Number of TOS metrics: 0
       TOS 0 Metrics: 781
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 3.3.3.3
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

r2#
we see we are recieving the advertisment from r3 but there is a problem the adv router is not reachable this is as the two routers do not agree on the database there is  an issue with spf running
if we look down at the routes we are not seeing r3 3.3.3.3 loopback

r2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 192.168.1.1, 00:05:28, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 10.164.49.2, 00:05:28, FastEthernet0/0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/3] via 10.164.49.2, 00:05:28, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/67] via 10.164.49.2, 00:05:28, FastEthernet0/0
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/3] via 10.164.49.2, 00:05:29, FastEthernet0/0
     172.25.0.0/24 is subnetted, 1 subnets
O       172.25.13.0 [110/66] via 10.164.49.2, 00:05:29, FastEthernet0/0
     22.0.0.0/24 is subnetted, 1 subnets
C       22.22.22.0 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.10/32 [110/2] via 10.164.49.2, 00:05:30, FastEthernet0/0
O       10.229.254.0/24 [110/2] via 10.164.49.2, 00:05:30, FastEthernet0/0
C       10.164.49.0/24 is directly connected, FastEthernet0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
O       192.168.1.1/32 [110/64] via 192.168.1.1, 00:05:30, Serial0/0
C       192.168.1.0/24 is directly connected, Serial0/0
r2#