Sunday, December 4, 2011

Frame Relay Switch Install

Frame-Relay Switch Install

Configuration of frame relay switch on cisco router  for labs is fairly straight forward

I am using a cisco 2610 with serial 8 a/s card. I have my dce of my serial cables
connected to the cisco 2610 fr switch and the dte connected to the relevant routers
The first thing that needs to be done in global config mode on the fr switch is to
enable frame-relay switching
router(config)#frame-relay switching
then you go to your relevant serial interface depending on the device you are
connecting so I am doing router 6 which connects to s1/4 on my frame relay switch
this is going to communicate to router 5 on interface serial 1/5
int s1/4
encap frame-relay
clock rate 56000
frame-relay intf-type dce
no frame inverse
frame-relay route 122 interface serial 1/5 221

int s1/5
encap frame-relay
clock rate 56000
frame-relay intf-type dce
no frame inverse
frame-relay route 221 interface serial 1/4 122

As your dce you need to put clocking
The frame-relay route command breaks down as follow
frame-relay route 221 (r6 dlci) interface serial 1/4 (interface to outgoing dlci so r5
connected interface) 221 ( r5 dlci)

For the ine config i have the following physical connections for the routers to the frame relay switch
                        
r3 s1/0 is connected to s1/6
r3 s1/1 is connected to s1/7
r2 s0/0 is connected to s1/2
r1 s0/0 is connected to s1/0
r4 s0/0 is connected to s1/3
r5 s0/0 is connected to s1/5
r6 s0/0 is connected to s1/4
The config for the switch is below in full
fr#sh run
Building configuration...
Current configuration : 2982 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname fr
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
frame-relay switching
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 102 interface Serial1/2 201
 frame-relay route 103 interface Serial1/6 301
 frame-relay route 104 interface Serial1/3 401
 frame-relay route 105 interface Serial1/5 501
 frame-relay route 113 interface Serial1/7 311
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 encapsulation frame-relay
 clock rate 56000
 frame-relay intf-type dce
 frame-relay route 202 interface Serial1/0 102
 frame-relay route 203 interface Serial1/6 302
 frame-relay route 204 interface Serial1/3 402
 frame-relay route 205 interface Serial1/5 502
 frame-relay route 213 interface Serial1/7 312
!
interface Serial1/3
 no ip address
 encapsulation frame-relay
 shutdown
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 401 interface Serial1/0 104
 frame-relay route 402 interface Serial1/2 204
 frame-relay route 403 interface Serial1/6 304
 frame-relay route 405 interface Serial1/5 504
 frame-relay route 413 interface Serial1/7 314
!
interface Serial1/4
 no ip address
 encapsulation frame-relay
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 51 interface Serial1/1 51
 frame-relay route 100 interface Serial1/1 100
 frame-relay route 101 interface Serial1/1 101
 frame-relay route 201 interface Serial1/1 201
 frame-relay route 301 interface Serial1/1 301
 frame-relay route 401 interface Serial1/1 401
!
interface Serial1/5
 no ip address
 encapsulation frame-relay
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 501 interface Serial1/0 105
 frame-relay route 502 interface Serial1/2 205
 frame-relay route 503 interface Serial1/6 305
 frame-relay route 504 interface Serial1/3 405
 frame-relay route 513 interface Serial1/7 315
!
interface Serial1/6
 no ip address
 encapsulation frame-relay
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 301 interface Serial1/0 103
 frame-relay route 302 interface Serial1/2 203
 frame-relay route 304 interface Serial1/3 403
 frame-relay route 305 interface Serial1/5 503
!
interface Serial1/7
 no ip address
 encapsulation frame-relay
 clock rate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 311 interface Serial1/0 113
 frame-relay route 312 interface Serial1/2 213
 frame-relay route 314 interface Serial1/3 413
 frame-relay route 315 interface Serial1/5 513
!
ip http server
ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

No comments:

Post a Comment